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Fehlerbehebung für Windows SharePoint Services

Microsoft SharePoint Services wird vom Windows SharePoint Services-Adapter verwendet. In diesem Thema werden einige bekannte, möglicherweise auftretende Probleme mit Windows SharePoint Services sowie mögliche Lösungen für diese Probleme beschrieben.

Bekannte Probleme

Beim Versuch, die Inhaltsdatenbank zu erstellen, tritt ein Fehler bei der Anmeldung für Benutzer 'NT-AUTORITÄT\NETZWERKDIENST' auf

Problem

Wenn Sie versuchen, mithilfe der Website SharePoint-Zentraladministration eine Inhaltsdatenbank zu erstellen, wird eine Fehlermeldung ähnlich der folgenden angezeigt:

Fehler bei der Anmeldung für den Benutzer 'NT AUTHORITY\NETWORK SERVICE'.

Ursache

Dieses Problem tritt auf, wenn der Besitzer der Datenbank, mit der Sie eine Verbindung herstellen möchten, nicht mit der Anwendungspoolidentität übereinstimmt, unter der Windows SharePoint Services ausgeführt wird.

Lösung

Führen Sie Lösen dieses Problems eine der folgenden Aktionen aus:

  • Gewähren Sie dem Netzwerkdienstkonto die Berechtigung zum "Erstellen von Datenbanken" in SQL Server.

  • Ändern Sie das Konto der Anwendungspoolidentität in ein Konto, das über die Berechtigung zum "Erstellen von Datenbanken" in SQL Server verfügt.

Beim Versuch, die Website "SharePoint-Zentraladministration" aufzurufen, tritt der Fehler "Dienst nicht verfügbar" auf

Problem

Beim Versuch, die Website SharePoint-Zentraladministration zu öffnen, wird eine Fehlermeldung ähnlich der folgenden angezeigt:

Dienst nicht verfügbar

Ursache

Die häufigste Ursache für diesen Fehler besteht darin, dass der Anwendungspool (IIS 6.0 oder IIS 7.0) oder die hostende COM+-Anwendung (IIS 5.x) für die Website SharePoint-Zentraladministration beendet wurde. Dies tritt häufig auf, wenn der Anwendungspool oder die COM+-Anwendung mit einer Identität konfiguriert ist, für die der angegebene Benutzername und/oder das angegebene Kennwort ungültig ist.

Lösung

Führen Sie die Schritte im Abschnitt "Festlegen der IIS-Anwendungshostprozessidentität" des Themas Richtlinien zum Beheben von PROBLEMEN mit IIS-Berechtigungen aus, um die entsprechende Hostprozessidentität festzulegen.

Beim Versuch, eine Inhaltsdatenbank zu erstellen und zu erweitern, tritt der Fehler 'Es kann keine Verbindung zur Konfigurationsdatenbank hergestellt werden' auf.

Problem

Wenn Sie mithilfe der Website SharePoint-Zentraladministration versuchen, eine Inhaltsdatenbank zu erstellen und zu erweitern, wird eine Fehlermeldung ähnlich der folgenden angezeigt:

Es kann keine Verbindung zur Konfigurationsdatenbank hergestellt werden.

Ursache

Dieser Fehler tritt auf, wenn das vom Anwendungspool verwendete Konto, über das die Website SharePoint-Zentraladministration ausgeführt wird, nicht über die erforderlichen Berechtigungen für die SQL Server-Datenbank verfügt.

Lösung

Führen Sie Lösen dieses Problems eine der folgenden Aktionen aus:

  • Gewähren Sie dem Konto, das vom Anwendungspool für die Website SharePoint-Zentraladministration verwendet wird, die Berechtigung zum Erstellen von Datenbanken in SQL Server.

  • Ändern Sie das Konto der Anwendungspoolidentität in ein Konto, das über die Berechtigung zum "Erstellen von Datenbanken" in SQL Server verfügt.

Nach dem Neustart des Servers wird im Anwendungsprotokoll ein Fehler generiert mit der Aussage, dass der SharePoint-Timerdienst nicht gestartet werden konnte

Problem

Nach dem Neustart des Servers wird ein Fehler im Ereignisprotokoll angezeigt mit etwa folgendem Text:

Fehler beim Starten des SharePoint-Timerdiensts

Beim Öffnen der Website SharePoint-Zentraladministration kann ebenfalls der folgende Fehler angezeigt werden:

Es kann keine Verbindung zur WSS-Konfigurationsdatenbank 'STS_Config' hergestellt werden

Ursache

Dieser Fehler tritt auf, wenn der SharePoint-Zeitgeberdienst nach dem Neustart keine Verbindung mit der SharePoint Services Datenbank herstellen kann. Der SharePoint-Timerdienst wird verwendet, um Benachrichtigungen zu senden und geplante Aufgaben für SharePoint Services auszuführen. Fehler beim Starten des SharePoint-Timerdiensts treten häufig auf, wenn das verwendete Konto zum Ausführen des Diensts mit einer Identität konfiguriert wurde, für die der Benutzername oder das Kennwort ungültig sind.

Lösung

Stellen Sie sicher, dass der angegebene Benutzername und das Kennwort für die SharePoint-Timerdienstanmeldung korrekt sind und der Dienst gestartet wurde.