Vertrauensanker für den Zertifizierungspfad beim Einrichten der App-Verbindung nicht gefunden
Problembeschreibung
Wenn Sie versuchen, eine Verbindung mit Supply Chain Management herzustellen, wird in der Warehouse Management-App möglicherweise die folgende Fehlermeldung angezeigt:
java.security.cert.certPathValidatorException: Vertrauensanker für den Zertifizierungspfad nicht gefunden.
Dieses Problem kann sich auf Geräte mit den folgenden Eigenschaften auswirken:
- Betriebssystemversion: Android 4.4.x (z. B. Zebra TC55). Dies ist kein Problem bei aktuellen Android-Versionen.
- Standort des Supply Chain Management: Cloud
- Verbindungsmodus: Geheimer Clientschlüssel oder Zertifikat
Mögliche Ursache
Microsoft hat möglicherweise die ssl-Serverzertifikate aktualisiert, die von Supply Chain Management verwendet werden. Daher hat sich das Stammzertifikat und/oder eines der Zwischenzertifikate möglicherweise geändert, sodass das neue Zertifikat nicht in der Liste der vertrauenswürdigen Systemzertifikate für das mobile Gerät enthalten ist. Neuere Versionen von Android aktualisieren automatisch die Listen vertrauenswürdiger Zertifikate, aber Android 4.4.x nicht.
Lösung
Führen Sie einen der folgenden Schritte aus, um dieses Problem zu beheben:
- Verwenden Sie die im nächsten Abschnitt beschriebene Problemumgehung, um jedes relevante Gerät zu aktualisieren.
- Es kann möglich sein, Zebra oder Google zu kontaktieren, um ein Update der vertrauenswürdigen Zertifizierungsstellenzertifikate des Systems zu erhalten. Wir haben dies jedoch nicht bestätigt.
- Wenn möglich, erwägen Sie, ältere Geräte durch Geräte zu ersetzen, die eine neuere Version von Android ausführen (wobei vertrauenswürdige Zertifizierungsstellenzertifikate automatisch aktualisiert werden).
Problemumgehung
Schritt 1: Exportieren des neuen Stammzertifikats aus Supply Chain Management
Laden Sie das neue Stammzertifikat mithilfe Ihres Internetbrowsers manuell herunter, indem Sie die folgenden Schritte ausführen:
- Melden Sie sich bei Dynamics Supply Chain Management an, und öffnen Sie die Startseite.
- Wählen Sie in der Adressleiste Ihres Browsers das Sperrsymbol aus, um das Dialogfeld "Speicherort ist sicher " zu öffnen.
- Wählen Sie im Dialogfeld Zertifikat (gültig) aus, um das Zertifikatfenster für dieses Zertifikat zu öffnen.
- Öffnen Sie die Registerkarte "Zertifizierungspfad " im Fenster "Zertifikat ".
- Wählen Sie das oberste Zertifikat aus, das in der Hierarchie angezeigt wird. (dies ist das Stammzertifikat).
- Öffnen Sie die Registerkarte "Details " des Fensters "Zertifikat ".
- Wählen Sie unten auf der Registerkarte "Details" die Schaltfläche "In Datei kopieren" aus.
- Der Zertifikatexport-Assistent wird geöffnet. Klicken Sie auf Weiter, um fortzufahren.
- Die Seite "Dateiformat exportieren " wird geöffnet. Select DER encoded binary X.509 (. CER). Wählen Sie dann Weiter aus, um fortzufahren.
- Die Seite "Zu exportierende Dateien" wird geöffnet, geben Sie einen Dateinamen und speicherort an. Wählen Sie dann Weiter aus, um fortzufahren.
- Die Seite zum Abschließen des Zertifikatexport-Assistenten wird geöffnet, auf der das Ergebnis Ihres Exports angezeigt wird. Wählen Sie Fertig stellenaus.
Schritt 2: Installieren des heruntergeladenen Zertifikats auf den betroffenen Geräten
Installieren Sie das heruntergeladene Zertifikat wie folgt:
- Übertragen Sie das Zertifikat, das Sie im vorherigen Schritt heruntergeladen haben, auf das Gerät, das Sie aktualisieren möchten. Sie können beispielsweise eine SD-Karte oder Netzwerkverbindung verwenden, um die Datei auf Ihrem Gerät verfügbar zu machen.
- Öffnen Sie die Sicherheitseinstellungen für Ihr Gerät, und wählen Sie die Menüoption zum Installieren eines Zertifikats aus einer Datei aus. (Die genauen Schritte hierfür variieren je nach Geräte- und Betriebssystemversion.)
- Das neue Zertifikat sollte jetzt auf der Registerkarte "Benutzer " für vertrauenswürdige Zertifikate angezeigt werden.
- Wiederholen Sie dieses Verfahren für jedes betroffene Gerät.