Die mobile Field Service-App kann aufgrund von Berechtigungs- oder Berechtigungsproblemen nicht gestartet werden.
Dieser Artikel enthält eine Lösung für den Fehler "Prinzipalbenutzer fehlt Berechtigungen", der auftritt, wenn die mobile Field Service-App nicht gestartet werden kann.
Problembeschreibung
Die mobile Dynamics 365 Field Service-App kann nicht mit dem folgenden Fehler gestartet werden:
Prinzipalbenutzer (ID=<GUID>, ...) fehlt die Berechtigung "prvReadmsdyn_Mobile" (ID=<GUID>) für OTC=<INT> für die Entität "msdyn_mobilesource" ...
Ursache
Die neue Benutzeroberfläche in der mobilen Dynamics 365 Field Service-App erfordert bestimmte Berechtigungen in den Sicherheitsrollen der Benutzer.
Lösung
Das System fügt automatisch die erforderlichen Berechtigungen allen Standardsicherheitsrollen hinzu. Wenn Ihre Organisation jedoch benutzerdefinierte Sicherheitsrollen verwendet, müssen Sie die Sicherheitsrollen bearbeiten, um die folgenden Tabellenberechtigungen hinzuzufügen:
- Name=
"msdyn_richtextfile"
Permission="Create" Value="User" - Name=
"msdyn_richtextfile"
Permission="Delete" Value="User" - Name=
"msdyn_richtextfile"
Permission="Read" Value="User" - Name=
"msdyn_richtextfile"
Permission="Write" Value="User" - Name=
"msdyn_MobileSource"
Permission="Read" Value="Organization" - Name=
"msdyn_solutioncomponentsummary"
Permission="Read" Value="Organization" - Name=
"SettingDefinition"
Permission="Read" Value="Organization" - Name=
"Solution"
Permission="Read" Value="Organization" - Name=
"SettingDefinition"
Permission="Read" Value="Organization"
Tipp
Wenn Sie den Namen der benutzerdefinierten Sicherheitsrolle nicht kennen, erweitern Sie Benutzer + Berechtigungen, wählen Sie "Benutzer" aus, und suchen Sie nach dem Benutzer, der die Fehlermeldung erhält. Beachten Sie die Sicherheitsrolle des Benutzers, und überprüfen Sie die Tabellenberechtigungen für diese Sicherheitsrolle.