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Ein unbeaufsichtigter Desktopablauf schlägt mit dem FEHLER "MSEntraMachineAlwaysPromptingForPassword" fehl.

Dieser Artikel enthält eine Lösung für einen Fehler, der auftritt, wenn Sie einen unbeaufsichtigten Desktopfluss in Microsoft Power Automate für Desktop ausführen.

Problembeschreibung

Der unbeaufsichtigte Desktopablauf schlägt mit dem Fehlercode "MSEntraMachineAlwaysPromptingForPassword" fehl (früher "AADMachineAlwaysPromptingForPassword").

{
    "error":{
        "code": "MSEntraMachineAlwaysPromptingForPassword",
        "message": "Could not create unattended session with these credentials."  
    }    
}

Screenshot des Fehlercodes im Abschnitt

Ursache

Power Automate für Desktop können Ihre Microsoft Entra-ID (vormals Azure Active Directory) nicht auf dem Computer überprüfen. Dieses Problem wird in der Regel durch eine Gruppenrichtlinieneinstellung auf Ihrem Computer verursacht.

Lösung

Um dieses Problem zu beheben, überprüfen Sie die Gruppenrichtlinieneinstellung auf Ihrem Computer.

  1. Drücken Sie die WINDOWS-TASTE+R , um das Dialogfeld "Ausführen " zu öffnen.

  2. Geben Sie "gpedit.msc" ein, und drücken Sie die EINGABETASTE, um den Editor für lokale Gruppenrichtlinien zu öffnen.

  3. Navigieren Sie zu administrativen Vorlagen>für Die Computerkonfiguration>: Windows-Komponenten>remotedesktopdienste>Remotedesktop-Sitzungshostsicherheit.>

  4. Suchen Sie nach der Einstellung der Verbindung immer nach Kennwort.

    • Wenn die Einstellung aktiviert ist, arbeiten Sie mit Ihrer IT-Abteilung zusammen, um die Richtlinie für diesen Computer zu deaktivieren.

      Notiz

      Dieser Wert wird auch in der Registrierung unter Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services widerspiegelt. Wenn der fPromptForPassword-DWORD-Wert für den Terminaldiensteschlüssel auf 1 festgelegt ist, ist die Einstellung aktiviert, und Sie müssen mit Ihrer IT-Abteilung arbeiten, um ihn zu deaktivieren (das einfache Ändern des Registrierungswerts ist im Allgemeinen nicht ausreichend, da er wiederhergestellt werden kann.)

    • Wenn die Eingabe von Kennwort bei verbindungseinstellungen nicht aktiviert ist, Sie aber den Fehlercode erhalten, geben Sie im Dialogfeld "Ausführen" regedit ein, um den Registrierungs-Editor zu öffnen. Navigieren Sie im Registrierungs-Editor zum Registrierungsschlüssel "Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp ". Suchen Sie dann nach dem fPromptForPassword DWORD , und legen Sie ihn auf 0 fest. Wenn das DWORD nicht vorhanden ist, erstellen Sie es, und legen Sie den Wert auf 0 fest.