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Explizites falsch eingefügtes SPN-Problem in SQL Server

Dieser Artikel hilft Ihnen beim Beheben eines SQL Server-einheitlichen Authentifizierungsproblems, das sich auf den expliziten falsch eingefügten Dienstprinzipalnamen (SPN) auswirkt.

Symptome

Wenn der im Verbindungszeichenfolge angegebene SPN in einem Dienstkonto vorhanden ist, das von Microsoft SQL Server nicht verwendet wird, erhalten Sie eine SSPI-Kontextmeldung (Security Support Provider Interface).

Wenn der SPN nicht ordnungsgemäß registriert ist, wird möglicherweise die folgende Fehlermeldung angezeigt:

Der Zielprinzipalname ist falsch. Der SSPI-Kontext kann nicht erstellt werden.

Wenn Sie versuchen, einen bereits vorhandenen SPN zu erstellen, wird die folgende Fehlermeldung angezeigt:

Doppelter SPN-Vorgang gefunden, abgebrochen!

Ursache

Die explizit falsch eingefügten SPNs können Probleme bei der Kerberos-Authentifizierung verursachen und verhindern, dass Clients eine Verbindung mit dem Dienst herstellen.

Lösung

Wenn explizit falsch eingefügte SPNs aufgetreten sind, müssen Sie möglicherweise den SPN für den Dienst erstellen oder erneut erstellen. Führen Sie die folgenden Schritte aus, um den SPN mithilfe des SETSPN Befehls zu erstellen oder erneut zu erstellen:

  1. Führen Sie den SETSPN -L domain\svcacct Befehl aus, um SPNs im SQL Server-Dienstkonto auflisten.
  2. Führen Sie den SETSPN -Q spnName Befehl aus, um zu erfahren, für welches Dienstkonto der SPN registriert ist.
  3. Führen Sie den SETSPN -D Befehl aus, um den SPN aus dem Dienst zu entfernen.
  4. Führen Sie den SETSPN -A Befehl aus, um den SPN zum Dienst hinzuzufügen.
  5. Verschieben Sie den SPN mithilfe SETSPN -Dvon SPN, oder wählen Sie einen SPN aus, der bereits im richtigen Konto vorhanden ist.

Weitere Informationen

Konsistente Authentifizierungsprobleme in SQL Server