Troubleshoot the ERR_VHD_FILE_NOT_FOUND error code (124)
This article discusses how to identify and resolve the ERR_VHD_FILE_NOT_FOUND
error code (error code number 124) that occurs when you try to create and deploy a Microsoft Azure Kubernetes Service (AKS) cluster.
Symptoms
When you try to create an AKS cluster, you receive the following error message:
VMExtensionProvisioningError: VM has reported a failure when processing extension 'vmssCSE'.
Error message: "Enable failed: failed to execute command: command terminated with exit status=124
Cause
Under rare circumstances, the 124 exit code for the Azure Virtual Machine Scale Set custom script extension (vmssCSE
) might happen instead of the following error codes:
Error code name | Error code number |
---|---|
OutboundConnFailVMExtensionError |
50 |
K8SAPIServerConnFailVMExtensionError |
51 |
K8SAPIServerDNSLookupFailVMExtensionError |
52 |
This error occurs if a connectivity issue exists between your AKS cluster and the required Azure endpoints, such as mcr.microsoft.com
or acs-mirror.azureedge.net
.
Solution
Review outbound network and FQDN rules for Azure Kubernetes Service (AKS) clusters and make sure that all API services FQDN are allowed.
For detailed troubleshooting steps, refer to the troubleshooting guides in the following articles:
Troubleshoot the OutboundConnFailVMExtensionError error code (50)
Troubleshoot the K8SAPIServerConnFailVMExtensionError error code (51)
Troubleshoot the K8SAPIServerDNSLookupFailVMExtensionError error code (52)
References
Contact us for help
If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.