Users receive NDR 5.2.0 when they send meeting invites in Microsoft 365 hybrid environment
Original KB number: 4038474
Symptoms
After a delegate's or manager's mailbox is moved to a new forest in Microsoft 365, users receive the following non-delivery report (NDR) when they send meeting invites to the manager:
Remote Server returned '554 5.2.0 STOREDRV.Deliver.Exception:DelegateUserValidationException; Failed to process message due to a permanent exception with message Delegate user validation failed for user:DelegateName. DelegateUserValidationException: Delegate user validation failed for user:DelegateName. [Stage: OnCreatedEvent[Agent: Meeting Message Processing Agent]'
Cause
The delegate's old value for the legacyExchangeDN
attribute is stored on the local free/busy object in the manager's mailbox.
Resolution
The manager should readd the delegate after making sure that there are no cached references to the delegate's original object. To do this, follow these steps:
Remove all delegates from the Delegates dialog box in Outlook.
Note
Before you move on to the next steps, confirm whether the issue is now resolved. If users continue to receive an NDR when they send meeting invites to the manager, continue through the remaining steps to make sure that all cached delegate information is removed from the mailbox.
Sign in to the mailbox through Outlook Web App (OWA), and then confirm that all delegates are removed. Follow these steps to check delegates in OWA:
Sign in to the mailbox through OWA.
Open the calendar.
Select Share from the menu at the top.
Select the trash can icon to remove any delegates.
Remove any auto-complete entries for the delegates. To do this, follow these steps:
Start a new mail message.
Type the delegate's name.
Highlight the entry in the pop-up window, and then select the X to delete the entry.
Force the Offline Address Book (OAB) to download. This should happen automatically every 24 hours, but it's important to have the most recent version to make sure that the correct delegate information is stored in the manager's mailbox.
On the Send/Receive menu, select Send/Receive Groups, and then select Download Address Book.
Select OK.
A progress bar is displayed when the OAB is downloading. Depending on the size of the file and the network connection, this process might take several minutes to complete.
After these steps are complete, add a new delegate, and then confirm that new meeting invites are delivered to the manager successfully.