Can't add a Room or Resource mailbox in a Microsoft 365 hybrid environment
Original KB number: 3161713
Symptoms
When you try to add a cross-forest Room or Resource mailbox in Outlook, you receive the following error message despite having Full Access permissions:
The name cannot be resolved. The name cannot be matched to a name in the address list.
Mail user objects that represent cross-forest Shared and User mailboxes can be successfully added as an additional mailbox in Outlook.
Cause
Mail user objects that represent a Room or Resource mailbox in another forest aren't considered ACL-able objects by Exchange Server. Therefore, they are not found by Outlook.
Note
ACL-able objects are objects that can be added to the access control list (ACL) for an object in Active Directory Domain Services (AD DS).
Workaround 1
Add the mailbox by using the LegacyExchangeDN
attribute or the X500 email address instead of using the display name or SMTP address.
Workaround 2
Add the mailbox as an additional email account. To do this, follow these steps:
Select File > Info, and then select Account Settings.
Select Account Settings.
On the E-mail tab, select New.
On the Auto Account Setup page, enter the Room mailbox name, e-mail address, and your account password.
Click Next.
AutoDiscover will find the mailbox and configure the account.
Workaround 3
If you only need to manage the calendar of the Room or Resource mailbox, you can add the mailbox calendar. For more information, see View multiple calendars at the same time.
Workaround 4
Administrators can change the calendar processing settings to enable automatic management of meeting requests. There are different settings that let you create restriction policies for private or reserved resources. For more information, see Set-CalendarProcessing.