"Your request couldn't be completed. Please try again" error when you try to search the audit log in Microsoft 365
Original KB number: 3193501
Problem
When a user tries to search the audit log in the Office 365 Security & Compliance Center, the user receives the following error message:
Your request couldn't be completed. Please try again, and if the problem persists, contact your administrator.
Cause
The user isn't assigned to the View-Only Audit Logs role or the Audit Logs role in Exchange Online.
Solution
Create a custom role group in the Exchange admin center, add the View-Only Audit Logs or Audit Logs role, and then add the user as a member of the new role group:
- Open the Exchange admin center. For more information, see Exchange admin center in Exchange Online.
- Select Permission > admin role, and then select New ( ) to create a new role group.
- On the 'New role group' page:
- Specify a name for the role group.
- In the Role box, select Add ( ), add the View-Only Audit Log or Audit Log role, and then select OK.
- In the Member box, select Add ( ), add the user, and then select Save.
More information
For more information, see Search the audit log in the compliance portal.
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