You can't recover deleted items from a non-mail public folder in Outlook 2016
Original KB number: 4010160
Symptoms
When you try to recover deleted items from a non-mail public folder (such as a calendar public folder or a contacts public folder) in Microsoft Outlook 2016, the Recover Deleted Items option does not appear in the following situations:
- You right-click the public folder.
- You select the Folder tab on the Outlook ribbon.
Cause
This behavior is by design. In Outlook 2010 or later versions, the Recover Deleted Items option is removed from the Folder tab on the ribbon for non-mail public folders. In Outlook 2016, the Recover Deleted Items option is also removed from the shortcut menu.
Workaround
To recover deleted items from a non-mail public folder, you can add the Recover Deleted Items action by customizing either the Quick Access Toolbar or the ribbon in Outlook 2016, as follows.
Customize the Quick Access Toolbar
To add the Recover Deleted Items command to the Quick Access Toolbar, follow these steps:
Select File > Options > Quick Access Toolbar.
On the Choose commands from menu, select All Commands.
Select Recover Deleted Items > Add.
Note
Don't add the Recover Deleted Items from Server command. This command is unavailable (dimmed) for non-mail public folders.
Customize the ribbon
To add the Recover Deleted Items command to the ribbon, you must either add a group to an existing tab or create a tab that has a new group. In these steps, a new group is added to the Folder tab. To add the command, follow these steps:
Select File > Options > Customize Ribbon.
In the details pane, select the Folder tab, and then select New Group.
Note
This creates New Group (Custom).
Press and hold (or right-click) the New Group (Custom) group, select Rename, and then enter a name (such as Recover).
In the Choose commands from list, select All Commands.
Select Recover Deleted Items > Add.
Important
Don't add the Recover Deleted Items from Server command. The command is unavailable (dimmed) for non-mail public folders.