Can't identify the user shown in an error message in Dynamics 365 Field Service

This article resolves an issue where you can't identify the user shown in a Field Service error message that contains the user ID.

Symptoms

In Microsoft Dynamics 365 Field Service, you receive an error message that contains a user ID from Dataverse, but you can't identify the user.

Cause

The Dataverse error message related to a user shows the Dynamics 365 Field Service user ID instead of the Microsoft Entra ID user ID. In addition, the Dataverse user ID is specific to the environment.

Resolution

Note

You need administrator permissions in Dynamics 365 Field Service to perform the steps.

To identify the user, follow these steps:

  1. In the Field Service app, select your Field Service environment.

  2. In the bottom left corner, select Settings > Users.

  3. Select a user, and the systemuser&id appears at the end of the URL.

    Screenshot that shows the Field Service Settings Users page with the systemuser&id highlighted.

  4. Replace the ID number with the ID shown in the error message, and then press Enter . The user's account tied to this ID appears.