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Se produce un error de privilegios al intentar usar microsoft Dynamics 365 App for Outlook

En este artículo se proporciona una solución para el problema que puede recibir el error De privilegios necesarios (prvReadOrganization) al intentar usar la aplicación Microsoft Dynamics 365 para Outlook.

Se aplica a: Microsoft Dynamics 365 Customer Engagement Online
Número de KB original: 4563997

Síntomas

Al intentar usar la aplicación Microsoft Dynamics 365 para Outlook, se produce un error al hacer referencia a un privilegio que falta, como el siguiente:

No tiene privilegios necesarios (prvReadOrganization), que limita ciertas funcionalidades. Póngase en contacto con el administrador para obtener el acceso necesario.

Causa

Este error aparecerá si el usuario asociado al registro de buzón no tiene privilegios suficientes para usar la aplicación Microsoft Dynamics 365 para Outlook.

Solución

Opción 1: Asignar el rol de seguridad de usuario de Microsoft Dynamics 365 App for Outlook

Existe un rol estándar para proporcionar los privilegios necesarios para usar microsoft Dynamics 365 App for Outlook. Este rol se denomina Aplicación de Microsoft Dynamics 365 para outlook y se puede asignar a los usuarios que necesitan usar la aplicación para Outlook. Para obtener más información sobre este rol, consulte Proporcionar acceso a roles de seguridad.

Opción 2: Rol personalizado

Si prefiere personalizar un rol para incluir los privilegios necesarios, consulte la sección Más información para obtener una lista de privilegios necesarios para usar la aplicación Microsoft Dynamics 365 para Outlook.

Más información

En la tabla siguiente se enumeran los privilegios necesarios para usar la aplicación de Microsoft Dynamics 365 para Outlook y la pestaña en un rol de seguridad donde se puede encontrar el privilegio. Un usuario con el rol Administrador del sistema puede buscar y modificar un rol de seguridad; para ello, vaya a Configuración roles> de seguridad de seguridad.> Para ver qué roles se asignan a un usuario específico, vaya a Configuración, seleccione Seguridad, seleccione Usuarios, seleccione el registro de usuario específico y, a continuación, seleccione Administrar roles.

Nombre de privilegio Entity Ubicación (pestaña) dentro de rol de seguridad
prvReadEmailServerProfile EmailServerProfile Administración de empresas
prvReadRole Rol de seguridad Administración de empresas
prvReadUser Usuario Administración de empresas
prvWriteMailbox Buzón Administración de empresas
prvReadMailbox Buzón Administración de empresas
prvReadOrganization Organización Administración de empresas
prvSyncToOutlook (exchangesyncidmapping Sincronizar con Outlook Administración empresarial:> privilegios relacionados con la privacidad
prvUseOfficeApps Usar Dynamics 365 App for Outlook Administración empresarial:> privilegios relacionados con la privacidad
prvAppendToAccount Cuenta Registros principales
prvReadAccount Cuenta Registros principales
prvDeleteActivity Actividad Registros principales
prvAppendActivity Actividad Registros principales
prvWriteActivity Actividad Registros principales
prvCreateActivity Actividad Registros principales
prvReadActivity Actividad Registros principales
prvAppendToActivity Actividad Registros principales
prvShareActivity Actividad Registros principales
prvAppendToContact Contacto Registros principales
prvReadContact CONTACTO Registros principales
prvCreateContact CONTACTO Registros principales
prvReadUserQuery Vista guardada Registros principales
prvReadAppModule Aplicación basada en modelo Personalización
prvReadAttribute Campo Personalización
prvReadEntity Entity Personalización
prvReadRelationship Relación Personalización
prvReadSystemApplicationMetadata Metadatos de aplicación del sistema Personalización
prvReadSystemForm Formulario del sistema Personalización
prvReadUserApplicationMetadata Metadatos de aplicación del usuario Personalización
prvReadQuery Vista Personalización
prvReadWebResource Recurso web Personalización
prvSearchAvailability Buscar disponibilidad Administración de servicios:> privilegios varios

En la tabla siguiente se enumeran los privilegios adicionales necesarios para ver algunas de las vistas predeterminadas que se usan dentro de los formularios de La aplicación de Microsoft Dynamics 365 para Outlook. Sin estos privilegios, un usuario puede ver el siguiente error en lugar de la vista esperada (subgrid) de registros:

No tiene permiso para acceder a estos registros. Póngase en contacto con el administrador de Microsoft Dynamics 365 para obtener ayuda.

Nombre de privilegio Entity Ubicación (pestaña) dentro de rol de seguridad
prvReadIncident Case Servicio
prvReadOpportunity Oportunidad Registros principales
prvReadCompetitor Competidor Ventas
prvReadConnection Conexión Registros principales