Impossible d’utiliser les interfaces ODBC, OLEDB ou DAO Access en dehors des applications Office Démarrer en un clic
Symptômes
Lorsque vous essayez de créer un DSN ODBC pour les pilotes fournis par Microsoft Access dans l’administrateur ODBC des sources de données, la tentative échoue. Ce problème se produit si vous utilisez une installation Démarrer en un clic (C2R) d’Office qui n’expose pas le moteur de base de données Access en dehors de la bulle de virtualisation Office. Selon la version d’Office, vous pouvez rencontrer l’un des problèmes suivants lorsque vous essayez cette opération :
Les pilotes ODBC fournis par ACEODBC.DLL ne sont pas répertoriés dans la boîte de dialogue Sélectionner un pilote .
Vous recevez un message d’erreur « Le système d’exploitation n’est pas actuellement configuré pour exécuter cette application ».
Vous recevez un message d’erreur « Impossible de charger odbcji32.dll ».
Vous recevez un message « Le pilote de ce nom de domaine utilisateur n’existe pas. Il ne peut être supprimé que » message d’erreur avec la plateforme affichant N/A.
Pilotes affectés :
- Pilote Microsoft Access (*.mdb, *.accdb)
- Pilote de texte Microsoft Access (*.txt, *.csv)
- Pilote Microsoft Excel (*.xls, *.xlsx, *.xlsm, *.xlsb)
En outre, si vous essayez de définir une connexion OLEDB à partir d’une application externe (qui s’exécute en dehors d’Office) à l’aide du fournisseur OLEDB Microsoft.ACE.OLEDB.12.0 ou Microsoft.ACE.OLEDB.16.0, vous rencontrez une erreur « Fournisseur introuvable » lorsque vous essayez de vous connecter au fournisseur.
Cause
Les installations « Démarrer en un clic » d’Office s’exécutent dans un environnement virtuel isolé sur le système d’exploitation local. Certaines applications en dehors d’Office peuvent ne pas savoir où rechercher l’installation dans l’environnement isolé.
Résolution
À compter de Microsoft 365 Apps for Enterprise Version 2009, le travail a été effectué pour sortir ACE de la bulle de virtualisation C2R afin que les applications en dehors d’Office puissent localiser les interfaces ODBC, OLEDB et DAO fournies par le moteur de base de données Access dans l’installation C2R.
Utilisez le tableau suivant pour comprendre si des composants supplémentaires sont nécessaires pour accéder à ces interfaces au sein de votre environnement :
Installation actuelle d’Office | Composants supplémentaires nécessaires | Installation supplémentaire recommandée |
---|---|---|
Microsoft 365 Apps for Enterprise, Office 2016/2019/2021 Consumer Version 2009 ou ultérieure | Non | - |
Office LTSC 2021 (licence en volume) | Non | - |
Office 2016/2019 Pro Plus C2R (licence en volume) | Oui | Mettre à niveau vers Office LTSC 2021 (licence en volume) ou installer Microsoft Access 2013 Runtime |
Office 2010/2013/2016 MSI | Non | - |
Aucune installation d’Office | Oui | Microsoft 365 Access Runtime |
Remarque
- Le redistribuable Moteur de base de données Microsoft Access 2016 n’est pas fourni en tant qu’installation recommandée, car le moteur de base de données Access 2016 et les applications Microsoft 365 utilisent le même identificateur de version principale (16.0), ce qui peut introduire des comportements inattendus. La détection côte à côte d’Office empêche également l’installation de continuer si ce scénario est détecté.
Plus d’informations sur la création de connexions ODBC
Toutes les instances « Démarrer en un clic » d’Office ne peuvent pas créer de noms de sources de données machine/système à partir d’une application Office ou de l’administrateur ODBC des sources de données.