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Activation Windows - ID d’ordinateur client en double

S’applique à : ✔️ Machine virtuelles Windows

Nous vous recommandons généralement d’utiliser des serveurs Azure Service de gestion de clés s (KMS) pour activer des machines virtuelles Windows Azure, même quand Azure Hybrid Benefit est activé. Toutefois, dans certains cas, étant donné que les restrictions réseau peuvent empêcher les machines virtuelles de communiquer avec des serveurs AZURE KMS, vous pouvez utiliser un serveur KMS auto-hébergé pour l’activation. Cet article traite d’un problème d’ID d’ordinateur client en double qui se produit lorsque vous utilisez un serveur KMS auto-hébergé pour l’activation de Windows et fournit une solution.

Note

Cet article s’applique uniquement lorsque vous utilisez un serveur KMS auto-hébergé pour l’activation. Elle ne s’applique pas lorsque vous utilisez Azure KMS pour l’activation.

Symptômes

Lorsque vous utilisez un serveur KMS auto-hébergé pour l’activation et que vous essayez d’activer plusieurs machines virtuelles Windows Server, l’activation échoue après la période d’évaluation, et votre serveur KMS auto-hébergé signale l’erreur suivante dans le rapport d’ID d’ordinateur client en double :

Le rapport d’ID d’ordinateur client en double permet d’identifier les ordinateurs de l’environnement qui exécutent des images qui n’ont pas été correctement généralisées à l’aide de l’outil Sysprep avant le déploiement.
Remarque :
- Plusieurs clients d’activation en volume avec le même CMID sont comptabilisés comme un seul client par KMS. Si cela entraîne l’échec du nombre de clients KMS au-dessous du seuil minimal, l’activation KMS échoue dans votre environnement.

Cause

  • L’ID de l’ordinateur client (CMID) est effacé pendant le processus Sysprep de l’image source d’origine. Toutefois, si le processus Sysprep est déclenché avec le paramètre SkipRearm défini 1 sur la valeur 0par défaut , le CMID ne sera pas effacé. Dans ce cas, toutes les machines virtuelles créées à partir de cette image auront le même CMID.

  • Lorsque vous créez des machines virtuelles à partir de Place de marché Azure, Place de marché Azure images pour Windows Server ont été généralisées avec le paramètre SkipRearm défini sur 1. Par conséquent, les machines virtuelles créées à partir de la même image Windows Server auront le même CMID.

Confirmer le CMID dupliqué

Vérifiez si les machines virtuelles ont le même CMID en fonction de l’image source et de la version :

  1. Exécutez la commande suivante sur les machines virtuelles problématiques :

    cscript C:\Windows\System32\slmgr.vbs /dlv
    

    Voici un exemple de sortie de commande :

    Most recent activation information:
    Key Management Service client information
        Client Machine ID (CMID): <client-machine-ID>
        Registered KMS machine name: <KMS-machine-name>
    
  2. Comparez les sorties de commande sur les machines virtuelles problématiques et vérifiez si les machines virtuelles ont le même CMID.

Solution

  • Pour les machines virtuelles problématiques créées à partir d’une image personnalisée, généralisez/sysprep la machine virtuelle d’origine avec le paramètre SkipRearm défini pour 0 vous assurer que le CMID est effacé de l’image.

  • Pour les machines virtuelles problématiques déjà déployées, procédez comme suit :

    1. Exécutez la commande slmgr /rearm dans une invite de commandes avec élévation de privilèges.

    2. Redémarrez la machine virtuelle.

    3. Une fois la machine virtuelle en ligne après le redémarrage, exécutez la commande suivante pour vérifier que le CMID a été modifié :

      cscript C:\Windows\System32\slmgr.vbs /dlv
      
    4. Déclenchez à nouveau l’activation.

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