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La suppression des contrats SLA ou des éléments SLA affiche une erreur dans Unified Interface lors d’une mise à niveau de solution ou d’une suppression manuelle

Cet article fournit une solution au problème où la suppression de contrats de niveau de service (SLA) ou d’éléments SLA affiche un message d’erreur dans Unified Interface lors d’une mise à niveau de solution ou d’une suppression manuelle.

Symptômes

Lorsque vous essayez de supprimer des contrats SLA ou des éléments SLA lors d’une mise à niveau de solution ou d’une suppression manuelle, l’un des messages d’erreur suivants se produit :

L’objet que vous avez tenté de supprimer est associé à un autre objet et ne peut pas être supprimé.

L’opération de suppression SLAItem a rencontré des erreurs. Le processus fait partie d’une solution managée et ne peut pas être supprimé individuellement. Désinstallez la solution parente pour supprimer le processus. Pour plus d’informations, consultez journal.

Cause

Le premier message d’erreur se produit car, dans le contrat SLA d’interface unifiée, la relation entre l’élément SLA et les instances d’indicateur de performance clé SLA est définie sur « Restreindre à supprimer ». Le deuxième message d’erreur se produit, car les processus qui font partie d’une solution managée ne peuvent pas être supprimés. Si vous essayez de supprimer manuellement un contrat SLA qui fait partie d’une solution managée et dont les flux sont configurés, le message d’erreur s’affiche.

Résolution 1

Au lieu de supprimer le contrat SLA, désactivez-le dans votre organization. S’il fait partie d’une solution managée, procédez comme suit :

  1. Désactivez le contrat SLA dans le instance source et ajoutez-le à la solution.
  2. Désactivez le même contrat SLA dans le instance cible, puis appliquez la mise à niveau de la solution.

Résolution 2

Vous pouvez d’abord supprimer manuellement tous les enregistrements d’entité liés au contrat SLA et les instances d’indicateur de performance clé SLA, puis supprimer le contrat SLA. Voici les étapes à effectuer :

  1. Dans votre organization, accédez à Recherche avancée, recherchez Instances d’indicateur de performance clé SLA, puis sélectionnez SLAItem.
  2. Sélectionnez Résultat. Les instances d’indicateur de performance clé SLA sont répertoriées.
  3. Sélectionnez les instances d’indicateur de performance clé SLA requises, puis sélectionnez Supprimer SLAKPIInstances. Cela nullifie également les instances d’indicateur de performance clé SLA sur les enregistrements associés.

Même après la suppression des enregistrements de référence, si le message d’erreur « Opération de suppression SLAItem a rencontré des erreurs. Le processus fait partie d’une solution managée et ne peut pas être supprimé individuellement. Désinstallez la solution parente pour supprimer le processus. Pour plus d’informations, consultez le journal », puis appliquez la mise à niveau de la solution avec le contrat SLA supprimé de la solution de mise à niveau.

Résolution 3

Si la résolution ci-dessus ne fonctionne pas, contactez Support Microsoft pour demander la suppression des éléments SLA ou SLA.