La suppression d’un contrat SLA ou d’éléments SLA affiche une erreur dans l’interface unifiée lors d’une mise à niveau de solution ou d’une suppression manuelle
Cet article fournit une résolution du problème où la suppression des contrats de niveau de service (SLA) ou des éléments SLA affiche un message d’erreur dans l’interface unifiée lors d’une mise à niveau de solution ou d’une suppression manuelle.
Symptômes
Lorsque vous essayez de supprimer des contrats SLA ou des éléments SLA lors d’une mise à niveau de solution ou d’une suppression manuelle, l’un des messages d’erreur suivants se produit :
L’objet que vous avez tenté de supprimer est associé à un autre objet et ne peut pas être supprimé.
L’opération de suppression SLAItem a rencontré des erreurs. Le processus fait partie d’une solution gérée et il ne peut pas être supprimé individuellement. Désinstallez la solution parente pour supprimer le processus. Pour plus d’informations, consultez le journal.
Cause
Le premier message d’erreur se produit, car, dans le contrat SLA de l’interface unifiée, la relation entre l’élément SLA et les instances d’indicateur de performance clé SLA est définie sur « Restreindre la suppression ». Le deuxième message d’erreur se produit, car les processus qui font partie d’une solution managée ne peuvent pas être supprimés. Si vous essayez de supprimer manuellement un SLA qui fait partie d’un solution gérée et dont les flux sont configurés, le message d’erreur s’affiche.
Résolution 1
Au lieu de supprimer le SLA, désactivez-le dans votre organisation. Si elle fait partie d’une solution managée, procédez comme suit :
- Désactivez le SLA dans l’instance source et ajoutez-le à la solution.
- Désactivez le même contrat SLA dans l’instance cible, puis appliquez la mise à niveau de la solution.
Résolution 2
Vous pouvez d’abord supprimer manuellement tous les enregistrements d’entité liés au contrat SLA et les instances de KPI SLA, puis supprimer le contrat SLA. Voici les étapes à suivre :
- Dans votre organisation, accédez à Recherche avancée, recherchez les instances de KPI SLA, puis sélectionnez SLAItem.
- Sélectionnez Résultat. Les instances SLA KPI seront répertoriées.
- Sélectionnez les instances de KPI SLA requises, puis sélectionnez Supprimez SLAKPIInstances. Cela annulera également les instances SLA KPI sur les enregistrements associés.
Même après la suppression des enregistrements de référence, si le message d’erreur « Opération de suppression SLAItem a rencontré certaines erreurs. Le processus fait partie d’une solution managée et ne peut pas être supprimé individuellement. Désinstallez la solution parente pour supprimer le processus. Pour plus d’informations, consultez la section « Application de la mise à niveau de la solution avec le contrat SLA supprimé de la solution de mise à niveau.
Résolution 3
Si la résolution ci-dessus ne fonctionne pas, contactez Support Microsoft pour demander la suppression des éléments SLA ou SLA.