Résoudre les problèmes liés aux transactions qui ne peuvent pas être réglées
Cet article fournit une résolution d’un problème où vous ne pouvez pas régler les transactions dans Microsoft Dynamics 365 Finance.
Symptômes
Parfois, vous ne pouvez pas régler les transactions car une autre activité traite actuellement le document. Si vous essayez de régler les transactions, une erreur se produit parce que ces transactions sont utilisées.
Cause
Les transactions sont marquées pour le règlement lorsque des factures fournisseur sont payées ou lorsque des clients paient leurs factures en cours. Parfois, ces factures peuvent déjà être marquées pour le règlement. Par conséquent, les utilisateurs ne peuvent pas les sélectionner pour le paiement. Les factures peuvent être marquées par un autre journal des paiements client, commande client, journal des paiements fournisseur ou commande fournisseur dans l’entité juridique actuelle ou une autre entité juridique.
Résolution
Pour résoudre ce problème, vous pouvez utiliser la page Détails de la transaction marquée pour rechercher les transactions marquées pour le règlement et identifier tout autre processus qui y accède.
Note
Pour pouvoir utiliser cette fonctionnalité, vous devez l’activer dans le système. Les administrateurs peuvent utiliser l’espace de travail de gestion des fonctionnalités pour vérifier l’état de la fonctionnalité et l’activer s’il est nécessaire. Là, la fonctionnalité est répertoriée de la manière suivante :
- Module : gestion de la trésorerie et de la banque
- Nom de la fonctionnalité : Formulaire de détail de la transaction marquée
Si une transaction est bloquée pour le règlement lorsque vous entrez un paiement client, accédez aux tâches>périodiques de comptes clients>marquées par les détails de transaction pour ouvrir la page détails de la transaction marquée par le client.
Pour identifier rapidement l’emplacement où une transaction est bloquée, vous pouvez définir l’un de ces paramètres de sélection : compte client, bon, date ou facture. Si vous ne définissez aucun paramètre de sélection, le système affiche tous les documents bloqués de la société actuelle ou d’une autre société que vous sélectionnez. Une fois que la transaction qui a été bloquée pour le règlement est identifiée, vous pouvez la sélectionner, puis sélectionner Supprimer le marquage des transactions sélectionnées. La transaction sélectionnée est ensuite supprimée de tous les journaux l’incluant. Cependant, le document n’est pas supprimé de l’autre emplacement. Seules les informations de marquage sont supprimées de ce journal.
Si une transaction est bloquée pour le règlement lorsque vous entrez un paiement fournisseur, accédez à Comptes payables>>Fournisseur marqué les détails de transaction marqués pour ouvrir la page détails de la transaction marquée par le fournisseur.
Pour identifier rapidement l’emplacement où une transaction est bloquée, vous pouvez définir l’un de ces paramètres de sélection : compte fournisseur, bon, date ou facture. Si vous ne définissez aucun paramètre de sélection, le système affiche tous les documents bloqués de la société actuelle ou d’une autre société que vous sélectionnez. Une fois que la transaction est identifiée, vous pouvez la sélectionner, puis sélectionner Supprimer le marquage des transactions sélectionnées pour réparer le problème bloquant. La transaction sélectionnée est ensuite supprimée de tous les journaux l’incluant. Cependant, le document n’est pas supprimé de l’autre emplacement. Seules les informations de marquage sont supprimées de ce journal.
Pour identifier tous les documents bloqués, accédez aux tâches>périodiques comptes clients>Tous les détails des transactions marquées ou les tâches>périodiques comptes payables>Toutes les détails de transaction marqués pour ouvrir la page Tous les détails de transaction marqués.
Pour identifier rapidement l’emplacement où une transaction est bloquée, vous pouvez définir l’un de ces paramètres de sélection : compte client, compte fournisseur, bon, date ou facture. Si vous ne définissez aucun paramètre de sélection, le système affiche tous les documents bloqués de la société actuelle ou d’une autre société que vous sélectionnez. Une fois que la transaction est identifiée, vous pouvez la sélectionner, puis sélectionner Supprimer le marquage des transactions sélectionnées pour réparer le problème bloquant. La transaction sélectionnée est ensuite supprimée de tous les journaux l’incluant. Cependant, le document n’est pas supprimé de l’autre emplacement. Seules les informations de marquage sont supprimées de ce journal.