L’importation de la solution échoue en raison de composants manquants
Cet article fournit une résolution de l’erreur échec de l’importation de la solution [nom de la solution] qui peut se produire lorsque vous essayez d’importer une solution dans Microsoft Dynamics 365.
S’applique à : Microsoft Dynamics 365
Numéro de la base de connaissances d’origine : 4346030
Symptômes
Lorsque vous tentez d’importer une solution dans Microsoft Dynamics 365, l’importation échoue avec le message suivant :
L’importation de la solution [nom de la solution] a échoué. Les composants suivants sont manquants dans votre système et ne sont pas inclus dans la solution. Importez les solutions managées qui contiennent ces composants ([nom de la solution manquante] ([version de la solution])), puis réessayez d’importer la solution.
Vous pouvez également voir une référence au code d’erreur 8004801d.
Cause
Cette erreur se produit si vous essayez d’importer une solution qui dépend d’autres composants qui ne figurent pas dans votre Dynamics 365 organization Microsoft.
Exemple : Vous avez un environnement de développement dans lequel vous avez créé une solution (Solution A) qui contient une entité personnalisée (Widget). Vous avez créé une autre solution (solution B) qui dépend d’un composant dans la solution A (par exemple, ajout d’un nouveau champ à l’entité Widget). Si vous essayez d’importer la solution B dans un autre organization (par exemple, votre organization de production) sur lequel la solution A n’est pas déjà installée, vous rencontrerez cette erreur.
Résolution
Passez en revue les détails du composant manquant affichés dans la boîte de dialogue d’importation. Si d’autres solutions répertoriées ne sont pas déjà importées dans le organization où vous essayez d’importer cette solution, importez d’abord ces solutions avant d’essayer d’importer cette solution.
Exemple : En suivant l’exemple de la section Cause ci-dessus, vous pouvez voir que la liste des composants manquants affiche une ou plusieurs lignes où la colonne Solution managée fait référence à la solution A. Cela indique que vous devrez importer la version mentionnée de la solution A pour pouvoir importer la solution B.
Plus d’informations
Si le message d’erreur fait référence à une solution Microsoft, reportez-vous à la liste suivante de solutions et à l’emplacement où elles peuvent être trouvées si elles ne sont pas installées dans le organization cible :
LinkedIn Sales Navigator pour Dynamics 365
Noms des solutions :
LinkedInSalesNavigatorControlsForUnifiedClient
LinkedIn
msdyn_LinkedInSalesNavigatorAnchor
Remarque
Si vous souhaitez désinstaller ces solutions, elles doivent être désinstallées dans l’ordre de la liste ci-dessus.