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Risoluzione dei problemi di Windows SharePoint Services

Microsoft SharePoint Services viene usato dall'adattatore Windows SharePoint Services. In questo argomento verranno illustrati alcuni problemi noti che è possibile riscontrare in Windows SharePoint Services e le relative possibili risoluzioni.

Problemi noti

Si verifica un errore "Accesso non riuscito per l'utente 'NT AUTHORITY\SERVIZIO DI RETE'"quando si tenta di creare un database del contenuto

Problema

Quando si tenta di creare un database del contenuto tramite il sito Web Amministrazione centrale SharePoint, viene visualizzato un errore simile al seguente:

Accesso non riuscito per l'utente 'NT AUTHORITY\NETWORK SERVICE'

Causa

Questo problema si verifica quando il proprietario del database a cui si esegue la connessione non corrisponde all'identità del pool di applicazioni con cui viene eseguito Windows SharePoint Services.

Risoluzione

Per risolvere il problema, eseguire una delle operazioni seguenti:

  • Concedere all'account SERVIZIO DI RETE diritti per la creazione di database in SQL Server.

  • Cambiare l'account identità del pool di applicazioni con un account che disponga di diritti per la creazione di database in SQL Server.

Si verifica l'errore "Servizio non disponibile" quando si accede al sito Web Amministrazione centrale SharePoint

Problema

Quando si tenta di aprire il sito Web Amministrazione centrale SharePoint, viene visualizzato un errore simile al seguente:

Servizio non disponibile

Causa

La causa più comune di questo errore è rappresentata dall'arresto del pool di applicazioni (IIS 6.0 o IIS 7.0) o dell'applicazione COM+ host (IIS 5.x) per il sito Web Amministrazione centrale SharePoint. Questa eventualità si verifica quando il pool di applicazioni o l'applicazione COM+ è configurata con un'identità per la quale la password e/o il nome utente specificato non sono validi.

Risoluzione

Seguire la procedura descritta nella sezione "Impostazione dell'identità del processo host dell'applicazione IIS" dell'argomento Linee guida per la risoluzione dei problemi relativi alle autorizzazioni IIS per impostare l'identità del processo host appropriata.

Si verifica un errore "Impossibile connettersi al database di configurazione" quando si tenta di estendere e creare un database del contenuto

Problema

Quando si tenta di estendere e creare un database del contenuto tramite il sito Web Amministrazione centrale SharePoint, viene visualizzato un errore simile al seguente:

Impossibile connettersi al database di configurazione

Causa

Questo problema si verifica quando l'account utilizzato dal pool di applicazioni che esegue il sito Web Amministrazione centrale SharePoint non dispone delle autorizzazioni necessarie per il database SQL Server.

Risoluzione

Per risolvere il problema, eseguire una delle operazioni seguenti:

  • Concedere all'account utilizzato dal pool di applicazioni per il sito Web Amministrazione centrale SharePoint diritti per la creazione di database in SQL Server.

  • Cambiare l'account identità del pool di applicazioni con un account che disponga di diritti per la creazione di database in SQL Server.

Nel log applicazioni viene generato un errore "Impossibile avviare il servizio Timer di SharePoint" dopo il riavvio del server.

Problema

Dopo il riavvio del server, nei registri eventi viene visualizzato l'errore seguente:

Impossibile avviare il servizio Timer di SharePoint

È inoltre possibile che venga visualizzato l'errore seguente quando si apre il sito Amministrazione centrale SharePoint:

Impossibile connettersi al database di configurazione WSS STS_Config

Causa

Questo errore si verifica quando il servizio Timer di SharePoint non riesce a contattare il database SharePoint Services dopo il riavvio. Il servizio Timer di SharePoint viene usato per inviare notifiche ed eseguire attività pianificate per SharePoint Services. La causa più frequente del mancato avvio del servizio Timer di Share Point è che l'account utilizzato per eseguire il servizio è configurato con un'identità per la quale il nome utente e/o la pasword non sono più validi.

Risoluzione

Verificare che il nome utente e la password specificati per l'account di accesso al servizio Timer di SharePoint siano corretti e che il servizio sia stato avviato.