Condividi tramite


Errore "ServiceUnavailable (409): la risorsa richiesta non è disponibile nel percorso"

Questo articolo illustra come risolvere l'errore ServiceUnavailable (409) ("La risorsa richiesta non è disponibile nel percorso" "<region-name>" in questo momento") che si verifica quando si tenta di distribuire una risorsa in Microsoft Istanze di Azure Container.

Sintomi

Viene visualizzato un messaggio di errore simile al testo seguente:

La risorsa richiesta non è attualmente disponibile nella località 'usgovvirginia'. Riprovare con una richiesta di risorsa diversa o in un'altra posizione. Risorsa richiesta: rete virtuale del sistema operativo '2' CPU '4' GB di memoria 'Linux'. ServiceUnavailable (409).

Causa

Questo problema può verificarsi se una funzionalità non è disponibile in determinate aree o se è presente una mancanza di capacità. Questo problema è in genere intermittente.

Soluzione

  1. Per determinare se è possibile eseguire la distribuzione in un'area disponibile, vedere Disponibilità delle risorse e limiti di quota per Istanze di Azure Container.

  2. Per determinare quali funzionalità sono disponibili nell'area, usare l'API REST Location - List Capabilities . È anche possibile verificare le funzionalità disponibili per area selezionando il pulsante "Prova" in tale articolo.

  3. Se si esegue la distribuzione in un'area disponibile e non sono previste limitazioni di funzionalità, ripetere la distribuzione.

Contattaci per ricevere assistenza

In caso di domande o bisogno di assistenza, creare una richiesta di supporto tecnico oppure formula una domanda nel Supporto della community di Azure. È possibile anche inviare un feedback sul prodotto al feedback della community di Azure.