Condividi tramite


Errore "Non è stato possibile abilitare la replica" nell'installazione della migrazione cloud

Questo articolo risolve un messaggio di errore che si verifica quando si esegue la guida alla configurazione assistita del programma di installazione della migrazione cloud in Business Central.

Sintomi

Quando si esegue la guida alla configurazione assistita dell'installazione di Migrazione cloud durante il processo di migrazione dei dati da locale a Business Central online, viene visualizzato il messaggio di errore seguente:

Impossibile abilitare la replica. Assicurarsi che il runtime di integrazione sia connesso correttamente e riprovare.

Causa

Il messaggio di errore può essere dovuto a diversi motivi. Tuttavia, il motivo più comune è una mancata corrispondenza tra la versione locale e le versioni di Business Central online e il tipo di prodotto scelto nella guida alla configurazione della migrazione cloud.

Risoluzione

Eseguire l'installazione della migrazione cloud e, quando si arriva alla pagina Scegli il prodotto, assicurarsi che il tipo di prodotto sia coerente con le versioni locali e online. I numeri di versione di Business Central devono avere il formato Major.Minor.Revision.Build , ad esempio 20.1.12345.67890.

  • Se le versioni principali locali e online sono le stesse, ad esempio 20.1 per l'ambiente locale e la versione 20.3 online, scegliere Dynamics Business Central versione corrente.
  • Se le versioni principali locali e online sono diverse, ad esempio 14.3 per locale e 20.3 per online, scegliere Dynamics Business Central versioni precedenti.

È possibile eseguire la query SQL seguente per verificare che il database locale contenga il numero di versione corretto:

SELECT [applicationversion]
FROM [$ndo$tenantdatabaseproperty]