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L'app per dispositivi mobili Field Service non viene avviata a causa di problemi di autorizzazione o privilegi

Questo articolo fornisce una risoluzione per l'errore "L'utente principale non ha privilegi mancanti" che si verifica quando l'app per dispositivi mobili Field Service non viene avviata.

Sintomi

L'app per dispositivi mobili Dynamics 365 Field Service non viene avviata con l'errore seguente:

Utente principale (Id=<GUID>, ...) manca il privilegio 'prvReadmsdyn_Mobile' (Id=<GUID>) in OTC=<INT> per l'entità 'msdyn_mobilesource' ...

Causa

La nuova esperienza utente nell'app per dispositivi mobili Dynamics 365 Field Service richiede determinati privilegi nei ruoli di sicurezza degli utenti.

Risoluzione

Il sistema aggiunge automaticamente i privilegi necessari a tutti i ruoli di sicurezza predefiniti. Tuttavia, se l'organizzazione usa ruoli di sicurezza personalizzati, è necessario modificare i ruoli di sicurezza per aggiungere i privilegi di tabella seguenti:

  • Nome="msdyn_richtextfile" Autorizzazione="Crea" Valore="Utente"
  • Nome="msdyn_richtextfile" Autorizzazione="Elimina" Valore="Utente"
  • Nome="msdyn_richtextfile" Autorizzazione="Leggi" Valore="Utente"
  • Nome="msdyn_richtextfile" Autorizzazione="Scrivi" Valore="Utente"
  • Nome="msdyn_MobileSource" Autorizzazione="Leggi" Valore="Organizzazione"
  • Nome="msdyn_solutioncomponentsummary" Autorizzazione="Leggi" Valore="Organizzazione"
  • Nome="SettingDefinition" Autorizzazione="Leggi" Valore="Organizzazione"
  • Nome="Solution" Autorizzazione="Leggi" Valore="Organizzazione"
  • Nome="SettingDefinition" Autorizzazione="Leggi" Valore="Organizzazione"

Suggerimento

Se non si conosce il nome del ruolo di sicurezza personalizzato, espandere Utenti e autorizzazioni, selezionare Utenti e cercare l'utente che riceve il messaggio di errore. Prendere nota del ruolo di sicurezza dell'utente ed esaminare i privilegi della tabella per tale ruolo di sicurezza.