Condividi tramite


L'area Impostazioni manca nella navigazione del modulo dell'app Field Service Mobile

Questo articolo fornisce una risoluzione per abilitare l'area Impostazioni nel riquadro di spostamento del modulo dell'app Field Service Mobile.

Sintomi

Il modulo dell'app Field Service Mobile non mostra l'area Impostazioni , impedendo agli amministratori di abilitare la nuova esperienza.

Causa

La nuova opzione Impostazioni esperienza mobile è disponibile tramite una nuova area di spostamento fornita con il modulo predefinito dell'app Field Service Mobile. Gli utenti devono disporre delle autorizzazioni di scrittura per l'entità FieldServiceSetting per accedere a questa area. I ruoli di sicurezza predefiniti, ad esempio Amministratore sistema o Amministratore di Field Service, dispongono di tale autorizzazione automaticamente. Tuttavia, se le personalizzazioni vengono effettuate sulla mappa della mappa del modulo dell'app Field Service Mobile predefinita, l'area Impostazioni potrebbe non essere visualizzata in alcuni casi.

Risoluzione

Innanzitutto, controlla se l'area della mappa del sito esiste sul livello predefinito della soluzione Field Service Mobile ma un livello di personalizzazione lo sovrascrive:

  1. Accedere a Power Apps.
  2. Passare all'ambiente e aprire la fieldservice_patch_update soluzione.
  3. Visualizza i livelli di soluzione per il componente msdyn_FSMobileSettingsArea nella soluzione fieldservice_patch_update.

Se si scopre che un livello di personalizzazione sulla mappa della mappa è in cima ed esegue l'override di questa area, usare una delle opzioni seguenti per abilitare l'area Impostazioni :

Opzione 1: Rimuovere il livello di personalizzazione della mappa del sito e personalizzarlo manualmente

  1. Rimuovere il livello di personalizzazione non gestita.
  2. Applicare nuovamente le personalizzazioni della mappa del sito.

Opzione 2: aggiungere manualmente l'area Impostazioni e passare alla mappa del sito

  1. Aprire l'app personalizzata nella finestra di progettazione app.

  2. Abilita le aree e crea una nuova area per le impostazioni di Field Service Mobile.

  3. Creare un nuovo gruppo per le impostazioni per dispositivi mobili.

  4. Aggiungere una nuova pagina al gruppo. Selezionare URL per il tipo di contenuto.

  5. Usare /main.aspx?etn=msdyn_fieldservicesetting&pagetype=entityrecord&id=e49c6117-5065-423f-8ab5-fcacfda85a04&formid=ee334fea-0cd5-471c-bb30-829f4511a59f come input URL.

  6. Aggiungere una sottoarea per le nuove funzionalità.

    1. In ID, espandi Impostazioni avanzate e privilegi.
    2. Selezionare Aggiungi impostazione di Field Service con privilegi di>tabella e quindi selezionare solo i privilegi di scrittura.
  7. Selezionare Applica>salva e pubblica.