Si verificano errori di connessione intermittenti quando si aggiunge un nodo all'ambiente AlwaysOn in SQL Server
Si verificano errori di connessione intermittenti quando si aggiunge un nuovo nodo all'ambiente Always On esistente.
Sintomi
Quando si tenta di connettersi a un server che esegue Microsoft SQL Server, viene visualizzato il messaggio di errore seguente in modo intermittente:
La connessione è stata stabilita correttamente con il server, ma si è verificato un errore durante il processo di accesso. (provider: provider SSL, errore: 0 - Una connessione esistente è stata chiusa forzatamente dall'host remoto.
Causa
Questo errore può verificarsi se si verifica una mancata corrispondenza nei protocolli di sicurezza tra il database e i server applicazioni.
Risoluzione
Per correggere questo errore, risolvere la mancata corrispondenza tra i protocolli di sicurezza. Node1 crittografa le informazioni usando AES128/256. Node2 crittografa le informazioni usando RC4. Per risolvere l'errore, seguire questa procedura:
Scaricare IIS Crypto.
Installare la versione GUI dello strumento di crittografia IIS nel server.
Configurare pacchetti di crittografia.
Aprire lo strumento di crittografia IIS nel server.
Nell'interfaccia di crittografia IIS selezionare Pacchetti di crittografia nel pannello sinistro.
Nell'elenco deselezionare tutte le caselle di controllo per le crittografie che iniziano con "TLS_DHE*".
Note
L'elenco potrebbe non essere in un ordine specifico.
Dopo aver cancellato le selezioni di crittografia pertinenti, selezionare Applica per salvare le modifiche.
Riavviare il server.
Dopo aver applicato le modifiche, riavviare il server per assicurarsi che la nuova configurazione della suite di crittografia abbia effetto.
Note
Questo processo di risoluzione dei problemi forza il client a comunicare usando una suite di crittografia diversa con un'implementazione di sicurezza migliorata.
Assicurarsi sempre di disporre dei backup appropriati. Valutare inoltre la possibilità di testare eventuali modifiche in un ambiente di test controllato, di staging o di test prima di applicarle ai computer di produzione. Se il problema persiste o se si verificano altri problemi, contattare il team di rete.
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