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Diagnosticare gli errori di replica di Active Directory

Questo articolo descrive come diagnosticare gli errori di replica di Active Directory.

Si applica a: tutte le versioni supportate di Windows Server
Numero KB originale: 2498185

Sintomi

È possibile notare che Active Directory non riesce a eseguire la replica nelle condizioni seguenti:

  • Lo strumento di monitoraggio Repadmin espone gli errori di replica.
  • Gli amministratori, gli utenti o le applicazioni rilevano che gli oggetti creati e modificati in Active Directory non esistono in tutti i controller di dominio in un ambito di replica comune.

Causa

La replica di Dominio di Active Directory Services (AD DS) presenta le dipendenze seguenti:

  • Connettività di rete sulle porte e sui protocolli usati dal servizio ADDS
  • Risoluzione dei nomi DNS per risolvere il nome di un partner di replica nell'indirizzo IP
  • Autenticazione e autorizzazione
  • Accuratezza temporale entro 5 minuti per supportare l'autenticazione Kerberos
  • Database di directory
  • Topologia di replica di Active Directory per compilare oggetti connessione tra partner di replica
  • Motore di replica ADDS

Risoluzione

Usare uno dei metodi seguenti per visualizzare gli errori di replica:

  • Scaricare ed eseguire lo strumento Assistente supporto e ripristino di Microsoft.

  • Leggere lo stato della replica nell'output repadmin /showrepl .

    • Repadmin fa parte di Remote Server Administrator Tools (RSAT). Se usi Windows 10 versione 1803 o una versione precedente di Windows, scarica Strumenti di amministrazione remota del server.If you're using Windows 10, version 1803 or an earlier version of Windows, download Remote Server Administration Tools (RSAT).

    • In Windows 10 versione 1809 e successive di Windows 10 puoi installare la funzionalità Strumenti di amministrazione remota del server tramite Impostazioni>Gestisci funzionalità facoltative.

Usare repadmin per identificare gli errori di replica di Active Directory a livello di foresta

È possibile creare un foglio di calcolo di Microsoft Excel per i controller di dominio usando il repadmin/showrepl comando per visualizzare gli errori di replica.

Note

Un modo più efficiente e pratico per produrre e analizzare il report, soprattutto se si vuole evitare di usare Excel, consiste nell'inviare l'output a una tabella interattiva in una finestra separata usando il comando di PowerShell:

repadmin /showrepl * /csv | convertfrom-csv | out-gridview

Per analizzare l'output usando Excel, seguire questa procedura:

  1. Aprire un prompt dei comandi come amministratore:

    Dal menu Start, fare clic con il pulsante destro del mouse su Prompt dei comandi, quindi fare clic su Esegui come amministratore. Se viene visualizzata la finestra di dialogo Controllo account utente, specificare le credenziali di Enterprise Admins e quindi selezionare Continua.

  2. Al prompt dei comandi digitare il comando seguente e quindi premere INVIO:

    repadmin /showrepl * /csv >showrepl.csv
    
  3. In Excel aprire showrepl.csv.

  4. Formattare il foglio di calcolo come segue:

    1. Nascondere o eliminare la colonna A e la colonna G.
    2. Selezionare la riga 1 sotto la riga dell'intestazione di colonna. Nella scheda Visualizza selezionare Blocca riquadri>Blocca riga superiore.
    3. Selezionare l'intero foglio di calcolo. Nella scheda Dati selezionare Filtro.
    4. Nella colonna Last Success Time (Ora ultima operazione riuscita) selezionare la freccia giù, puntare a Text Filters (Filtri di testo) e quindi selezionare Custom Filter (Filtro personalizzato).
    5. Ordinare la tabella dal meno recente al più recente.
    6. Nella colonna Controller di dominio di origine o Origine DSA selezionare la freccia giù del filtro, scegliere Filtri di testo e quindi selezionare Filtro personalizzato.
    7. Nella finestra di dialogo Filtro automatico personalizzato, in Mostra righe in cui selezionare non contiene. Nella casella di testo adiacente digitare del per eliminare i controller di dominio eliminati dalla visualizzazione.
    8. Ripetere il passaggio 6 per la colonna Ora ultimo errore, ma usare il valore non uguale e quindi digitare il valore 0.
  5. Per correggere eventuali errori di replica visualizzati in Stato ultimo errore, vedere Come risolvere gli errori comuni di replica di Active Directory.

Raccolta dei dati

Se è necessaria assistenza dal supporto tecnico Microsoft, è consigliabile raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni usando TSS per i problemi di replica di Active Directory.