BizTalk Server ツールのトラブルシューティング
このトピックでは、BizTalk Serverに含まれるツールの使用中に発生する一般的な問題に関する情報を一元的に提供します。
の既知の問題
UAC をサポートする Windows システムでは、BizTalk Server のツールおよびユーティリティが正しく機能しない場合がある
問題
ユーザー アカウント制御 (UAC) をサポートするシステムにBizTalk Serverがインストールされている場合、BizTalk Serverに含まれているツールが正常に起動しないか、正しく機能しない可能性があります。
原因
特定の特権レベルのフラグが設定されたアプリケーションを実行する場合、アプリケーションを実行するユーザーのレベルよりも高いレベルが必要なときは、UAC のメッセージが表示され、ユーザーは一時的にアプリケーション特権を必要なレベルに昇格できます。 BizTalk Serverに付属のツールでは、特権の昇格を自動的に要求するための適切なフラグが有効になっていないため、ツールはアプリケーションを実行しているユーザーの現在の特権レベルで実行を試み、より高い特権レベルが必要な場合は失敗します。
解決策
この問題を解決するには、すべての BizTalk Server ツールを管理者特権で実行します。 管理者特権でツールを実行するには、アプリケーションを右クリックし、[ 管理者として実行] を選択します。
ユーザー アカウント制御の詳細については、「」を参照してください https://go.microsoft.com/fwlink/?LinkId=99167。
BizTalk マッパー ツールボックスが空のように見える場合がある
問題
Visual Studio でマッパー ツールボックスを開いたときに、ツールボックスに Functoid がまったく表示されないことがあります。
原因
Visual Studio のアドインや修正プログラムのインストールまたはアンインストールによる破損の可能性があります。
解像度
これを解決するには、次の手順に従います。
Visual Studio の実行中のすべてのインスタンスを閉じます。
管理者として Visual Studio コマンド プロンプトを起動します。
コマンド プロンプトで、次のコマンドを入力します。
devenv.exe /setup