Z レポートのデータ調整に関する問題
エラーコード: SYS103633
この記事では、Microsoft Dynamics 365 Commerce 本社の Z レポート のデータ調整に関する問題の解決策について説明します。
現象
- Z レポートに表示される金額と計算された明細書に表示される合計とには不一致があります。
- headquarters のトランザクションの行品目の数が正しくないか、トランザクションの明細合計と合計の間に不一致があります。
- headquarters のシフトに表示されるトランザクション数が Z レポートのトランザクション数より少ない。
- 上記のいずれかの理由により、明細書の転記が失敗します。
原因
前に記述した現象の最も一般的なルートの原因は、チャンネル データベース内の重複するトランザクション ID の生成です。 重複したトランザクション ID は次の理由で生成できます。
- Modern Point of Sale (MPOS) のローカル データベース ストレージが壊れている。
- MPOS にはオフライン モードのトランザクションがいくつかあるので、オフライン データベースへのアクセス権がないアカウントを使用すると、そのトランザクションが再有効化されます。
- トランザクション ID の生成に関連するカスタマイズに問題があります。
解決策
通常、Commerce は番号順序に依存して連続するトランザクション ID を生成します。 何らかの理由で番号シーケンスが使用されたかどうかをシステムが判断できない場合は、重複するトランザクション ID が生成されます。
重複するトランザクション ID の問題を修正するには、サポート チケットを作成してトランザクション データを固定できるかどうかを確認します。 headquarters にデータが損失がない場合など、データの修正を行う必要がない場合があります。
この問題を防ぐには、headquarters で 重複するトランザクション ID 機能を回避するために、新しいトランザクション ID の有効化を有効にする必要があります。 この機能は、Microsoft Dynamics 365 Commerce バージョン 10.0.19 で導入されました。 これにより、各トランザクションに固有のトランザクション ID が作成され、連続するトランザクション ID が作成されるのを防ぐのに役立ちます。 この機能の詳細については、トランザクション ID の重複の防止 を参照してください。