サポートされていない種類のカードが原因でカードの支払いが失敗する
この記事は、Microsoft Dynamics 365 Commerce でクレジット カードまたはデビット カードトランザクションを処理するときに発生する "カードの種類は受け入れられた支払い形式ではありません" というエラーを解決するのに役立ちます。
現象
販売時点管理 (POS) で次のエラー メッセージが表示され、カード (またはギフト カード) の支払いが失敗します。
カードの種類は、受け入れ可能な支払い形式ではありません。 別の支払いカードを使用してから、もう一度やり直してください。
イベント ログには、次のエラー メッセージも表示されます。
ID 'Unknown' のカードの種類が見つかりません。
Note
エラー メッセージを受け取る前に、カードの支払いが正常に 認証 。 エラー メッセージが発生した後、カードの支払いは支払いサービスによって無効になります。
原因
チャネルの支払い方法用に構成カードの種類が、支払コネクタによって返される支払い情報と一致しません。
カードの種類は、ビン範囲、カードの種類 ID (Credit、Debit など)、およびエントリの種類 (Swipe
またはManual
) の組み合わせによって照合されます。
解決策 1
この問題を解決するには、カードの種類が入札の種類とチャネルに対して正しく構成されていることを確認します。
POS または Microsoft Dynamics Lifecycle Services (LCS) の POS クライアント ログで、使用されているカードの種類の値を確認するには、次のイベント名のイベント ログを確認します。
posPaymentCardTypeFilterByBinRangeIsDebitOrCredit
このイベントは、支払いプロセッサがカードの種類を Credit、 Debit、または Gift カードとして受け取ったかどうかを示。 値が期待どおりでない場合は、資金調達ソースが正しく設定または送信されない可能性があります。
posPaymentCardTypeFilterByBinRangeIsSwipe
このイベントは、ユーザーが POS を通じてカードをスワイプするか手動で入力するかを示します。 一致するビン範囲を持つカードの種類で手動入力が許可されていないが、スワイプ 入力でカードが入力された場合、一致するカードの種類が表示されない可能性があります。
Note
POS は、支払プロセッサまたはコネクタによって返されるカードの種類に基づいて、一致するビン範囲を検索します。
- カードの種類が "クレジット カード" の場合、POS はストアに設定されているすべてのカードの種類を "国際クレジット カード" として検索し、これらのカードの種類内で一致するビン範囲を探します。
- カードの種類が "デビット カード" の場合、POS はストアに設定されているすべてのカードの種類を "国際デビット カード" として検索し、これらのビン範囲内で一致します。
- 支払コネクタでカードの種類が設定されていない場合、POS では既定でクレジット カードと見なされ、"国際クレジット カード" タイプ内の一致が検索されます。
コマース本社で、 Retail and Commerce>Channel Setup>Payment メソッド>Card の種類に移動します。
- カード ブランドが存在するかどうかを確認します。 カード ブランドが見つからない場合は追加します。
- カードの種類 (国際クレジット カード または 国際デビットカード) がブランドに正しく割り当てられているかどうかを確認します。
- ツール バー カード番号 を選択し、受け取られていないカード番号をカバーするようにビン範囲が設定されていることを確認します。
Note
クレジット カードまたはデビット カードが正しく設定されていても、エラーが発生する場合は、支払いコネクタが間違ったカードの種類 ID を返した場合にエラーが発生する可能性があります。 たとえば、支払コネクタは "デビット カード" の種類を返しますが、コマース本社では "クレジット カード" の種類のみが設定されます。 このような場合は、クレジット カードとデビット カードの両方に同じビン範囲を持つカードの種類を作成します。
コマース本社で、問題のあるチャネルまたはストア フォームに移動します。
- Setup>支払い方法を選択しカードで使用する支払い方法を選択します。
- 電子決済の設定を選択しクレジット カードとデビット カードの両方の種類を支払い方法に追加します。
カードの種類または支払い方法に変更が加えられた場合は、CDX 1090 ジョブを実行し、その状態が 適用済みとして表示されることを確認します。
解決策 2
この問題を解決するには、Adyenに設定されているfundingSource
識別子を確認します。
Dynamics 365 Payment Connector for Adyen では、Adyen 承認応答の fundingSource
識別子に基づいてカードの種類が設定されます。 認証応答で fundingSource
識別子が Adyen によって設定されていない場合、カードの種類はコネクタで設定されません。 ただし、ビン範囲を探す場合、POS は既定で "クレジット" になります。
"bin 範囲が見つかりません" という問題があるが、最近カードの種類のビン範囲の設定を変更していない場合は、次のいずれかの理由が原因で問題が発生している可能性があります。
- Adyen ファームウェアの最近のアップグレードにより、
fundingSource
識別子の送信が開始されました。 fundingSource
識別子は、Adyen ポータルで最近有効になりました。- ビンの範囲は、その特定のカードまたはカードの種類に対して設定されていません。
Adyen ファームウェア バージョン 1.42.4 以前のバージョンでは、 fundingSource
識別子は必須ではなく、Adyen は送信に使用しません。 Adyen ファームウェア バージョン 1.44 以降のバージョンでは、資金調達ソースは POS ターミナルの必須フィールドとして承認応答で返送され、このプロパティは Adyen ポータルの構成によって制御されません。
Adyen ポータルで Funding Source を有効または無効にするには、次の手順に従います。
- Adyen ポータルにサインインします。
- 上部のナビゲーション バーで、 Account>API URL>追加データ設定を選択します。
- 下にスクロールして Funding Source 設定を見つけ、有効または無効にして、変更を保存します。
詳細
詳細については、「 Payment メソッドのセットアップ」を参照してください。
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