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SLA または SLA 項目を削除すると、ソリューションのアップグレード中または手動削除中に統合インターフェイスでエラーが表示される

この記事では、ソリューションのアップグレード中または手動削除中に、サービス レベル アグリーメント (SLA) または SLA 項目を削除すると統合インターフェイスでエラー メッセージが表示される問題の解決策について説明します。

現象

ソリューションのアップグレードまたは手動削除中に SLA または SLA 項目を削除しようとすると、次のいずれかのエラー メッセージが表示されます。

削除しようとしたオブジェクトは別のオブジェクトに関連付けられているので、削除できません。

SLAItem の削除操作で、いくつかのエラーが発生しました。 プロセスは管理ソリューションに含まれており、個別に削除できません。 親ソリューションをアンインストールして、プロセスを削除します。 詳細については、ログを参照してください。

原因

最初のエラー メッセージは、統合インターフェイスの SLA では、SLA 項目と SLA KPI インスタンスの関係が "削除に制限" に設定されているために発生します。2 番目のエラー メッセージは、マネージド ソリューションの一部であるプロセスを削除できないために発生します。 マネージド ソリューションの一部であり、フローが設定されている SLA を手動で削除しようとすると、エラー メッセージが表示されます。

解決策 1

SLA を削除する代わりに、組織で SLA を非アクティブ化します。 マネージド ソリューションの一部である場合は、次の手順を実行します。

  1. ソース インスタンスで SLA を非アクティブ化し、ソリューションに追加します。
  2. ターゲット インスタンスで同じ SLA を非アクティブ化し、ソリューションのアップグレードを適用します。

解決策 2

最初に、SLA 関連のすべてのエンティティ レコードと SLA KPI インスタンスを手動で削除してから、SLA を削除できます。 次に手順を示します。

  1. 組織で、 Advanced Find に移動し、 SLA KPI インスタンスを検索し、 SLAItem を選択します。
  2. 結果を選択します。 SLA KPI インスタンスが表示されます。
  3. 必要な SLA KPI インスタンスを選択してから、SLAKPIInstance の削除を選択します。 これにより、関連レコードの SLA KPI インスタンスも無効になります。

参照レコードを削除した後も、エラー メッセージ "SLAItem 削除操作でエラーが発生しました。 プロセスはマネージド ソリューションの一部であり、個別に削除することはできません。 親ソリューションをアンインストールして、プロセスを削除します。 詳細については、「ログ」を参照してください。その後、アップグレード ソリューションから削除された SLA を使用してソリューションのアップグレードを適用します。

解決策 3

上記の解決策が機能しない場合は、Microsoft サポートに連絡して、SLA または SLA 項目の削除を要求してください。