ポータルにチャット ウィジェットが読み込まれない
この記事では、オムニチャネル for Customer Service でチャット ウィジェットがポータルに読み込まれない問題に対して、いくつかの解決策を示します。
現象
チャット ウィジェットはポータルに読み込まれません。
原因
構成によっては、この問題が発生する理由が複数あります。 この問題を解決するには、5 つの方法があります。
解決 1: 場所オプション
チャット ウィジェットの Location オプションが正しく構成されていない可能性があります。
ウィジェットの場所 の場所を削除し、そしてそれを再作成します。
チャット ウィジェット Widget の場所 を削除して追加するには、次の手順に従います。
オムニチャネルの管理アプリにサインインします。
管理>チャット に移動
一覧のチャット ウィジェットを選択します。
配置 タブを選択します。
ウィジェットの配置 セクションでレコードを選択し、その後 削除 を選択します。
保存を選択します。
ウィジェットの場所 セクションで 追加 を選択して、レコードを追加します。 チャット ウィジェットの配置のための簡易作成ウィンドウが表示されます。
次の詳細情報を指定します。
Field 価値 Title レコードのタイトルを入力します。 Value チャット ウィジェットのある Web サイトのドメインが表示されます。 ドメイン形式にプロトコル ( http
またはhttps
) を含めることはできません。 たとえば、Web サイトはhttps://contoso.microsoftcrmportals.com
。 これで、値がcontoso.microsoftcrmportals.com
。保存を選択して、レコードを保存します。
Web サイト へ移動し、チャット ウィジェットが読み込まれるかどうかを確認します。
Note
チャット ウィジェットがブラウザーで機能するには、セッション ストレージとローカル ストレージが必要です。 これらのサービスが適切に機能できるように、ブラウザーで Cookie が有効になっていることを確認してください。
解決 2: 場所を削除する
または、チャット ウィジェットの場所を削除してみてください。
解決 3: ポータルのキャッシュをクリアする
次の手順を実行して、ポータル キャッシュをクリアします。
ポータルに移動し、ポータル管理者としてログインします。
次のテキストをポータル URL の末尾に追加します。
/_services/about
例:
https://contoso.powerappsportals.com/_services/about
キャッシュのクリア を選択します。
ポータルをリロードします。
また、Web ブラウザでサードパーティの Cookie が許可されていることを確認してください。
解決 4: ポータル構成を同期する
ポータルの構成を同期するには、次の手順を実行します。
Power Apps に移動します。
ポータルを見つけて選択し、 Edit を選択します。
同期構成 を選択します。
解決 5: ポータルを再起動する
次の手順を実行して、ポータルを再起動します。
Power Apps に移動します。
ポータルを選択し、 Advanced オプションで Settings>Administration を選択します。
再起動 を選択します。