Microsoft Dynamics 365 App for Outlook を使用しようとすると、特権エラーが発生する
この記事では、Microsoft Dynamics 365 App for Outlook を使用しようとすると、 必要な特権 (prvReadOrganization) エラーが発生する可能性がある問題の解決策について説明します。
適用対象: Microsoft Dynamics 365 Customer Engagement Online
元の KB 番号: 4563997
現象
Microsoft Dynamics 365 App for Outlook を使用しようとすると、次のエラーなど、不足している特権を参照するエラーが発生します。
特定の機能を制限する必要な特権 (prvReadOrganization) がありません。 必要なアクセス権を取得するには、管理者に問い合わせてください。
原因
このエラーは、メールボックス レコードに関連付けられているユーザーに、Microsoft Dynamics 365 App for Outlook を使用するための十分な権限がない場合に表示されます。
解決方法
オプション 1: Microsoft Dynamics 365 App for Outlook ユーザー セキュリティ ロールを割り当てる
Microsoft Dynamics 365 App for Outlook を使用するために必要な特権を提供するための標準ロールが存在します。 このロールは、Microsoft Dynamics 365 App for Outlook ユーザーという名前で、Outlook 用アプリを使用する必要があるユーザーに割り当てることができます。 このロールの詳細については、「 Provide セキュリティ ロールのアクセスを参照してください。
オプション 2: カスタム ロール
必要な特権を含むようにロールをカスタマイズする場合は、「Microsoft Dynamics 365 App for Outlook を使用するために必要な権限の一覧」セクションを参照してください。
詳細
次の表に、Microsoft Dynamics 365 App for Outlook を使用するために必要な権限と、権限が見つかるセキュリティ ロールのタブを示します。 システム管理者ロールを持つユーザーは、 Settings>Security>Security Roles に移動することで、セキュリティ ロールを見つけて変更できます。 特定のユーザーに割り当てられているロールを表示するには、 Settingsに移動し、 Security を選択し、 Users を選択し、特定のユーザー レコードを選択して、 管理ロールを選択します。
特権名 | エンティティ | セキュリティ ロール内の場所 (タブ) |
---|---|---|
prvReadEmailServerProfile | EmailServerProfile | ビジネス管理 |
prvReadRole | セキュリティ ロール | ビジネス管理 |
prvReadUser | User | ビジネス管理 |
prvWriteMailbox | メールボックス | ビジネス管理 |
prvReadMailbox | メールボックス | ビジネス管理 |
prvReadOrganization | 組織全体 | ビジネス管理 |
prvSyncToOutlook (exchangesyncidmapping | Outlook に同期 | ビジネス管理 - > プライバシー関連の特権 |
prvUseOfficeApps | Dynamics 365 App for Outlook の使用 | ビジネス管理 - > プライバシー関連の特権 |
prvAppendToAccount | アカウント | コア レコード |
prvReadAccount | アカウント | コア レコード |
prvDeleteActivity | 活動 | コア レコード |
prvAppendActivity | 活動 | コア レコード |
prvWriteActivity | 活動 | コア レコード |
prvCreateActivity | 活動 | コア レコード |
prvReadActivity | 活動 | コア レコード |
prvAppendToActivity | 活動 | コア レコード |
prvShareActivity | 活動 | コア レコード |
prvAppendToContact | 連絡先 | コア レコード |
prvReadContact | 連絡先 | コア レコード |
prvCreateContact | 連絡先 | コア レコード |
prvReadUserQuery | 保存されているビュー | コア レコード |
prvReadAppModule | モデル駆動アプリ | カスタマイズ |
prvReadAttribute | フィールド | カスタマイズ |
prvReadEntity | エンティティ | カスタマイズ |
prvReadRelationship | 関係 | カスタマイズ |
prvReadSystemApplicationMetadata | システム アプリケーション メタデータ | カスタマイズ |
prvReadSystemForm | システム フォーム | カスタマイズ |
prvReadUserApplicationMetadata | ユーザー アプリケーション メタデータ | カスタマイズ |
prvReadQuery | ビュー | カスタマイズ |
prvReadWebResource | Web リソース | カスタマイズ |
prvSearchAvailability | 空き時間の検索 | サービス管理 - > その他の特権 |
次の表に、Microsoft Dynamics 365 App for Outlook フォーム内で使用される既定のビューの一部を表示するために必要な追加の特権を示します。 これらの特権がないと、ユーザーは、レコードの予期されるビュー (サブグリッド) ではなく、次のエラーが表示される場合があります。
これらのレコードにアクセスするためのアクセス許可がありません。 Microsoft Dynamics 365 管理者に問い合わせてください。
特権名 | エンティティ | セキュリティ ロール内の場所 (タブ) |
---|---|---|
prvReadIncident | Case | Service |
prvReadOpportunity | 営業案件 | コア レコード |
prvReadCompetitor | 競合企業 | 営業 |
prvReadConnection | つながり | コア レコード |