インポート ファイルが大きすぎて、Microsoft Dynamics 365 でソリューションをインポートするときにアップロード エラーが発生する
この記事では、Microsoft Dynamics 365 でソリューションをインポートしようとしたときに発生するエラーの解決策について説明します。
適用対象: Microsoft Dynamics 365
元の KB 番号: 4462491
現象
Dynamics 365 でソリューションをインポートしようとすると、インポートが失敗し、次のメッセージが表示されます。
"インポート ファイルが大きすぎてアップロードが行えなすぎます。
エラー コード 80040375"
原因
エラー メッセージはインポートするソリューションの Maximum サイズに問題があることを示しますが SQL エラーなどの別の問題が原因である可能性があります。
解決方法
[ログ ファイルのダウンロード] ボタンを選択すると、より詳細なメッセージが表示されます。 次のメッセージなどの詳細が表示される場合があります。
インポートに失敗しました。 詳細については、関連するエラー メッセージを参照してください。 : 各テーブルの System.Data.SqlClient.SqlException (0x80131904) 列名は一意である必要があります。 テーブル '<entity/table name>' の列名 '<column name>' が複数回指定されています。
上記の例のメッセージは、そのエンティティに既に存在するフィールドをインポートしようとすると発生する可能性がある SQL エラーです。
例: Account エンティティに対して new_field1 という名前のスキーマ名を持つユーザー設定フィールドを組織内に作成した場合。 次に、Account エンティティに同じスキーマ名を持つフィールドを含むソリューションをインポートしようとしています。 SQL では、同じテーブル内の同じ名前の複数の列が許可されないため、インポートが失敗します。 ターゲット環境では、既に同じスキーマ名を持つフィールドがありますが、new_Field1やインポートするソリューション内のフィールドがnew_field1など、大文字と小文字が異なる場合があります。 ターゲット環境で同じ名前のフィールドが必要ない場合は、削除してからインポートを再試行してください。
エラーが解決せず、ログ ファイルの詳細を使用して問題を解決できない場合は、Microsoft サポートにお問い合わせください。 ログ ファイルの情報を使用して、 Dynamics 365 コミュニティ内の潜在的なソリューションを検索することもできます。