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動的ワークシートにアプリ データをエクスポートした後に "すべて更新" が機能しない

現象

Export to Excel コマンドを使用して、アプリ データを動的ワークシートにエクスポートします。 次に、ダウンロードしたファイルを開き、 Data>Refresh All を選択してデータを更新します。 このような状況では、データが消え、ブックが空白で表示されます。 次のエラー メッセージが表示される場合があります。

この Web クエリはデータを返しません。 クエリを変更するには、[OK] をクリックし、数式バーの名前ボックスの矢印をクリックし、Web クエリの外部データ範囲の名前をクリックし、選択内容を右クリックして、[クエリの編集] をクリックします。

エクスポートされたアプリ データを更新した後に発生するデータ エラーが Web クエリから返されていないことを示すスクリーンショット。

原因

この問題は、アクセスするデータがパスワードで保護されていて、Excel ファイルが外部データ ソースにパスワードを送信できない場合に発生します。

解決方法

この問題を解決するには、Web クエリを編集して保存する必要があります。

  1. Excel ファイルで Data>Queries & Connections を選択します。

    [データ] タブの [クエリと接続] オプションを示すスクリーンショット。

  2. クエリと接続 ウィンドウがウィンドウの右側に開きます。 [ Connections タブで、クエリを右クリックし、 Properties を選択します。

    [クエリと接続] ペインのクエリの [プロパティ] 設定を示すスクリーンショット。

  3. プロパティの接続 ウィンドウが開きます。 [ Definition ] タブで、[クエリの編集 選択

    接続プロパティ ウィンドウの [クエリの編集] ボタンを示すスクリーンショット。

  4. メッセージが表示されたら、ユーザー名とパスワードを入力します。 アプリへのログインに使用するのと同じユーザーとパスワードを入力します。

  5. [Web クエリの 編集 ウィンドウで、 Go を選択します。 次のエラー メッセージが表示されます。

    このアクションを完了できません

    [Web クエリの編集] ウィンドウの [移動] ボタンを示すスクリーンショット。

  6. Web クエリの編集ウィンドウを閉じます。

  7. このようにして問題を解決します。 Data>Refresh All を選択して、ワークシート内のデータをもう一度更新します。

    Excel でアプリ データを更新する方法を示すスクリーンショット。

上記の手順で問題が解決しない場合は、次の追加の手順に従います。

  1. Edit Web クエリ ウィンドウのアドレス バーに次のリンクを入力して、Microsoft Dynamics 365 Customer Engagement の Advanced Settings ページにアクセスします。 OrgURLを組織の URL に置き換えることを忘れないでください。

    https://OrgURL/main.aspx?settingsonly=true

  2. 右上のプロファイル オプション リンクを使用してサインアウトし、適切な ID を使用してサインインし直します。

  3. サインインしたら、 Edit Web Query ウィンドウを閉じ、Excel ファイルで Data>Refresh All を選択します。 データは想定どおりに更新されます。

関連項目

Excel の動的ワークシートにデータをエクスポートする