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Kerberos チケットのKRB_AP_ERR_TKT_EXPIRED エラー

この記事は、Kerberos チケットに影響する可能性がある一貫した認証の問題を解決するのに役立ちます。

Kerberos は、クライアントまたはサーバー アプリケーションにセキュリティで保護された認証を提供するために秘密鍵を使用するプロトコルです。 認証を成功させるためにチケットがユーザーに発行されます。 通常、Kerberos チケットの有効期間は約 10 時間で、自動的に更新されます。

現象

キー配布センター (KDC) には、サービスが失敗したことを示す KRB_AP_ERR_TKT_EXPIRED エラー メッセージが表示されます。

原因

ユーザーが認証に期限切れのチケットを使用しようとすると、Kerberos 接続は失敗します。 詳細については、 Kerberos 認証のトラブルシューティング ガイダンスを参照してください。

解決方法

このエラーを解決するには、次の手順に従います。

  1. KLIST purge コマンドを使用してユーザー チケットをクリアするか、ログオフして再度ログオンするか、コンピューターを再起動します。

  2. 次のコマンドに示すように、 KLIST コマンドを SSPIClient ツールと共に使用して、Kerberos チケットとサービス プリンシパル名 (SPN) を表示および管理します。

    KLIST GET MSSQLSvc\SQLProd01.contoso.com:1433

詳細

SQL Server での一貫した認証の問題