다음을 통해 공유


Javax.Crypto.Spec Namespace

This package provides the classes and interfaces needed to specify keys and parameter for encryption.

Classes

ChaCha20ParameterSpec

This class specifies the parameters used with the ChaCha20https://tools.ietf.org/html/rfc7539 algorithm.

DESedeKeySpec

This class specifies a DES-EDE ("triple-DES") key.

DESKeySpec

This class specifies a DES key.

DHGenParameterSpec

This class specifies the set of parameters used for generating Diffie-Hellman (system) parameters for use in Diffie-Hellman key agreement.

DHParameterSpec

This class specifies the set of parameters used with the Diffie-Hellman algorithm, as specified in PKCS #3: Diffie-Hellman Key-Agreement Standard.

DHPrivateKeySpec

This class specifies a Diffie-Hellman private key with its associated parameters.

DHPublicKeySpec

This class specifies a Diffie-Hellman public key with its associated parameters.

GCMParameterSpec

Specifies the set of parameters required by a javax.crypto.Cipher using the Galois/Counter Mode (GCM) mode.

IvParameterSpec

This class specifies an initialization vector (IV).

OAEPParameterSpec

This class specifies the set of parameters used with OAEP Padding, as defined in the PKCS #1 standard.

PBEKeySpec

A user-chosen password that can be used with password-based encryption (PBE).

PBEParameterSpec

This class specifies the set of parameters used with password-based encryption (PBE), as defined in the PKCS #5 standard.

PSource

This class specifies the source for encoding input P in OAEP Padding, as defined in the PKCS #1 standard.

PSource.PSpecified

This class is used to explicitly specify the value for encoding input P in OAEP Padding.

RC2ParameterSpec

This class specifies the parameters used with the RC2http://www.ietf.org/rfc/rfc2268.txt algorithm.

RC5ParameterSpec

This class specifies the parameters used with the RC5http://www.ietf.org/rfc/rfc2040.txt algorithm.

SecretKeySpec

This class specifies a secret key in a provider-independent fashion.

SecretKeySpec.InterfaceConsts