Microsoft 클라우드 서비스에 로그인하려고 할 때 "AADSTS65005" 오류
증상
회사 앱을 사용하여 Microsoft 365, Microsoft Intune, Microsoft Dynamics, Microsoft Power BI 또는 Microsoft Azure와 같은 Microsoft Cloud Services 중 하나에 로그인하거나 인증하거나 페더레이션된 갤러리 앱을 Microsoft Entra ID 경우 다음과 같은 오류 메시지가 표시됩니다.
AADSTS65005: 클라이언트 애플리케이션이 리소스에 대한 액세스를 요청했습니다. 클라이언트가 필수ResourceAccess 목록에 이 리소스를 지정하지 않았기 때문에 이 요청이 실패했습니다.
원인
이 문제는 회사의 앱이 Microsoft Entra ID 등록되지 않았거나 올바른 권한이 적용되지 않았을 수 있기 때문에 발생합니다.
해결 방법
이 문제를 해결하려면 액세스하려는 서비스에 따라 다음 리소스 중 하나를 사용합니다.
- Microsoft 365: Microsoft 365 API에 액세스할 수 있도록 앱을 Microsoft Entra ID 수동으로 등록
- Dynamics CRM: Dynamics CRM에 애플리케이션 등록
- 페더레이션된 Single Sign-On에 대해 구성된 갤러리 애플리케이션에 로그인하는 문제
추가 정보
Microsoft Entra ID 앱을 등록하는 방법에 대한 자세한 내용은 다음 Microsoft 웹 사이트를 참조하세요.