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전환 상태의 컨테이너 그룹을 유지합니다

이 문서에서는 컨테이너 그룹이 Microsoft Azure Container Instances에서 무기한 전환 상태로 유지될 때 발생하는 운영 오류를 해결하는 방법을 설명합니다. 또한 컨테이너 그룹을 만들고, 시작, 다시 시작, 중지 또는 삭제하는 컨테이너 그룹 작업 중에 발생하는 오류에 대해서도 설명합니다.

증상

AKS(Azure Kubernetes Service) 클러스터 삭제와 같이 컨테이너 그룹 작업을 직접 또는 간접적으로 트리거하는 작업을 수행하는 경우 다음과 같은 오류 메시지가 표시됩니다.

InternalErrorCode: "ContainerGroupTransitioning"
StatusCode: "409"
메시지: "컨테이너 그룹 '<container-group-name>'이 여전히 전환 중입니다. 나중에 다시 시도하세요."

원인

컨테이너 그룹의 연속 시작 작업 중에 Container Instances의 사이드카 컨테이너는 예상대로 종료되지 않습니다. 이 경우 컨테이너 그룹이 성공 상태로 중단 됩니다 .

해결 방법 1: 컨테이너 그룹 중지 및 다시 시작

  1. Azure Portal에서 컨테이너 인스턴스를 검색하고 선택합니다.

  2. 컨테이너 인스턴스 목록에서 컨테이너 그룹(컨테이너 인스턴스)의 이름을 선택합니다.

  3. 컨테이너 그룹의 개요 페이지에서 중지를 선택하여 컨테이너 그룹을 중지합니다. 컨테이너 인스턴스 중지 대화 상자에서 예를 선택하여 이 작업을 확인합니다.

  4. 컨테이너 그룹이 완전히 중지될 때까지 기다립니다. (최대 3분이 걸릴 수 있습니다.)

  5. 시작을 선택하여 컨테이너 그룹을 다시 시작합니다.

솔루션 2: 실행되지 않는 컨테이너에 대한 컨테이너 그룹 중지(Logic Apps에서 배포)

Azure Logic App사용하여 컨테이너를 배포하는 경우 컨테이너의 상태를 확인합니다. 컨테이너가 실행 중 상태가 아닌 경우 컨테이너 그룹을 중지합니다. 자세한 내용은 ACI(Azure Container Instances) 및 ACI Logic Apps 커넥터를 사용하여 트리거를 기반으로 감정 분석 실행을 참조하세요.

참고 항목

컨테이너 그룹을 중지하거나 시작하기 전에 컨테이너의 상태를 확인하는 것이 좋습니다. 이미 실행 중인 컨테이너가 있는 컨테이너 그룹을 시작하는 경우 전환 상태 문제가 발생할 수 있습니다.

솔루션 3: 지원 티켓 열기

이전 솔루션이 문제를 해결하지 못하고 여전히 오류 메시지가 발생하는 경우 지원 티켓을 엽니다.

자세한 정보

도움을 요청하십시오.

질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.