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작업을 수행할 수 없거나 컨테이너 그룹이 잘못된 상태입니다

이 문서에서는 컨테이너 그룹 작업을 수행할 수 없거나 컨테이너 그룹이 잘못된 상태인 Microsoft Azure Container Instances의 시나리오를 해결하는 방법을 설명합니다.

증상

다음 문제 중 하나 이상이 발생합니다.

  • 컨테이너 그룹을 삭제하려고 하지만 이 시도로 인해 내부 서버 오류가 발생합니다.

  • Azure CLI에서 az container show 명령을 실행하려고 하지만 내부 서버 오류로 인해 명령이 실패합니다.

  • Azure Portal에서 컨테이너 그룹 리소스를 볼 수 있지만 이 리소스에 대한 작업은 수행할 수 없습니다.

  • 컨테이너 그룹은 잘못된 상태(예: 중지됨 또는 실패)로 유지됩니다.

원인

컨테이너 그룹의 관리 ID는 연결된 컨테이너 그룹을 삭제하려고 시도하기 전에 삭제되었습니다. 이 시나리오는 이 삭제 순서를 수동으로 수행하려고 하면 발생할 수 있습니다. 또한 모든 관리 ID 및 컨테이너 그룹을 포함하여 개발 리소스 그룹 내의 모든 리소스를 삭제하는 정기적으로 예약된 스크립트(예: 야간 스크립트 실행)가 있는 경우에도 발생할 수 있습니다. 스크립트는 올바른 순서로 리소스를 삭제하지 않습니다. 먼저 컨테이너 그룹을 인증하는 데 필요한 관리 ID를 삭제한 다음 컨테이너 그룹 자체를 삭제하려고 합니다.

해결 방법 1: 관리 ID를 삭제하기 전에 컨테이너 그룹 삭제

먼저 컨테이너 그룹을 삭제하고 삭제 작업이 완료되기를 기다린 다음 관리 ID를 삭제합니다.

해결 방법 2: 지원 티켓을 열어 컨테이너 그룹을 잘못된 상태로 만듭니다.

컨테이너 그룹 인증에 필요한 관리 ID를 먼저 삭제했기 때문에 잘못된 상태로 남아 있는 컨테이너 그룹이 있는 경우 지원 티켓을 엽니다. Microsoft 지원 영향을 받는 컨테이너 그룹을 중지하고 컨테이너 그룹 설정을 수정하는 데 필요한 다른 단계를 수행하는 데 도움이 될 수 있습니다.

자세한 정보

도움을 요청하십시오.

질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.