Microsoft Azure Recovery Services 에이전트 시스템 상태 백업 실패(오류 ID 8007007B)
이 문서에서는 MARS(Microsoft Azure Recovery Services) 에이전트를 사용하여 시스템 상태를 백업할 때 발생하는 오류의 증상과 해결 방법을 설명합니다.
원래 제품 버전: Azure Backup
원래 KB 번호: 4053355
증상
다음 오류 메시지 중 하나가 Microsoft Azure Recovery Services 에이전트 콘솔에서 실패한 시스템 상태 백업 작업에 해당하는 작업 세부 정보 대화 상자의 오류 탭에 나타납니다.
Windows Server Backup 작업이 실패하고 백업에 포함된 항목이 백업되지 않았다는 오류 메시지와 함께 작업을 수행할 수 없습니다. 자세한 오류: 파일 이름, 디렉터리 이름 또는 볼륨 레이블 구문이 잘못된 HResult: 80780049 DetailedHResult: 8007007B Goto https://go.microsoft.com/fwlink/?linkid=847810 로 이 문제를 해결합니다. (0x1873D)
시스템 기록기에서 잘못된 경로를 보고했기 때문에 Windows Server에서 시스템 상태 백업을 수행하지 못했습니다. Windows Server Backup 오류 메시지: 파일 이름, 디렉터리 이름 또는 볼륨 레이블 구문이 잘못된 HResult: 80780049 DetailedHResult: 8007007B Goto https://go.microsoft.com/fwlink/?linkid=859092 를 사용하여 이 문제를 해결합니다. (0x18770)
WSB 오류 로그를 클릭하면 다음과 유사한 오류 메시지가 포함된 파일이 열립니다.
Systemroot_pathduring 열거형 백업 오류: 오류 [0x8007007b] 파일 이름, 디렉터리 이름 또는 볼륨 레이블 구문이 잘못되었습니다.
원인
이 오류는 Windows Server 시스템 상태의 일부로 백업해야 하는 파일을 열거하는 데 필요한 파일 사양이 잘못 업데이트될 때 발생합니다.
해결
Warning
레지스트리 편집기 또는 다른 방법을 사용하여 레지스트리를 잘못 수정하는 경우 심각한 문제가 발생할 수 있습니다. 이러한 문제를 해결하려면 운영 체제를 다시 설치해야 할 수 있습니다. Microsoft에서는 이 문제의 해결을 보장하지 않습니다. 레지스트리 수정에 따른 책임은 사용자에게 있습니다.
파일 사양이 업데이트되었는지 확인하려면 다음 단계를 수행합니다.
WSB 오류 로그를 클릭할 때 열리는 파일에서 Systemroot_path 올바른지 확인합니다. 예를 들어 다음 오류 메시지의 Systemroot_path 다음과 유사
C:\Windows\\systemroot\
합니다.열거 중 c:\windows\systemroot\의 백업 오류: 오류 [0x8007007b] 파일 이름, 디렉터리 이름 또는 볼륨 레이블 구문이 잘못되었습니다.
관리자 권한 명령 프롬프트에서 다음 명령을 실행합니다.
diskshadow /l Output_File_Path
참고 항목
Output_File_Path 자리 표시자는 다음과 유사
C:\outputfilepath.txt
합니다.DISKSHADOW 프롬프트에서 다음 명령을 입력한 다음 각 명령 다음에 Enter 키를 누릅니다.
list writers detailed exit
2단계에서 지정한 출력 파일을 엽니다.
위의 예제에서 Systemroot_path
C:\Windows\\systemroot\
포함된 줄을 찾습니다. 예를 들어 줄은 다음과 유사해야 합니다. 파일 목록: 경로 = Systemroot_path\system32\drivers, Filespec = File_Spec_Path예를 들면 다음과 같습니다.
파일 목록: Path =
C:\windows\\systemroot\system32\drivers
, Filespec = winmad.sys레지스트리 편집기를 시작합니다. 이렇게 하려면 시작을 마우스 오른쪽 단추로 클릭하고 실행을 클릭하고 열기 상자에 regedit를 입력한 다음 확인을 클릭합니다.
다음 하위 키를 찾습니다.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
서비스를 마우스 오른쪽 단추로 클릭한 다음 찾기를 클릭합니다.
찾을 내용 상자에 5단계에서 찾은 File_Spec_Path 경로를 입력하고 다음 찾기를 클릭합니다.
예제:
검색 결과에는 ImagePath라는 레지스트리 키가 있습니다. 해당 값에 선행 백슬래시 ''가 있는 경우 해당 값을 두 번 클릭하고 제거합니다. 값이 백슬래시로 시작되지 않는 경우 Azure Portal에서 지원 요청을 제출합니다.
변경 전 변경 후 MARS 에이전트 콘솔로 돌아가서 지금 백업을 클릭하여 시스템 상태 백업을 시작합니다.
도움을 요청하십시오.
질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.