VM 시작이 다음 상태에서 중지되었습니다. "Windows가 준비 중입니다. Azure에서 컴퓨터를 끄지 마세요."
적용 대상: ✔️ Windows VM
이 문서에서는 Microsoft Azure에서 Windows VM(가상 머신)을 시작할 때 발생할 수 있는 "준비 중" 및 "Windows 준비" 화면에 대해 설명합니다. 지원 티켓에 대한 데이터를 수집하는 데 도움이 되는 단계를 제공합니다.
참고 항목
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증상
Windows VM이 시작되지 않습니다. 부팅 진단을 사용하여 VM의 스크린샷을 가져오는 경우 VM에 "준비 중" 또는 "Windows 준비 중" 메시지가 표시되는 것을 볼 수 있습니다.
원인
일반적으로 이 문제는 구성이 변경된 후 서버에서 마지막 다시 시작을 수행할 때 발생합니다. 구성 변경은 Windows 업데이트 또는 서버의 역할 또는 기능 변경에 의해 초기화될 수 있습니다. Windows 업데이트 경우 업데이트가 큰 경우 운영 체제에서 변경 내용을 다시 구성하는 데 더 많은 시간이 필요합니다.
해결 방법 1: 백업에서 VM 복원
VM의 최근 백업이 있는 경우 백업에서 VM을 복원하여 시작 문제를 해결할 수 있습니다.
해결 방법 2: OS 메모리 덤프 파일 수집
백업에서 VM을 복원할 수 없거나 문제를 해결하지 못하는 경우 크래시가 분석될 수 있도록 메모리 덤프 파일을 수집해야 합니다.
1단계: 덤프 파일을 직접 수집
1부: OS 디스크를 복구 VM에 연결
영향을 받는 VM의 OS 디스크 스냅샷을 만들어 백업을 만듭니다. 자세한 내용은 가상 하드 디스크의 스냅샷 만들기를 참조 하세요.
RDP(원격 데스크톱 프로토콜)를 사용하여 복구 VM에 원격으로 연결합니다.
영향을 받는 VM의 OS 디스크가 암호화된 경우 다음 단계로 이동하기 전에 암호화를 해제합니다. 자세한 내용은 암호화된 OS 디스크의 암호 해독을 참조 하세요.
2부: 덤프 파일 찾기 및 지원 티켓 제출
복구 VM에서 연결된 OS 디스크의 Windows 폴더로 이동합니다. 예를 들어 연결된 OS 디스크에 할당된 드라이브 문자가 F인 경우 F:\Windows로 이동합니다.
Memory.dmp 파일을 찾은 다음 지원 티켓을 제출하고 덤프 파일을 첨부합니다.
덤프 파일을 찾을 수 없는 경우 다음 단계로 이동하여 덤프 로그 및 직렬 콘솔을 사용하도록 설정한 다음 메모리 덤프 프로세스를 트리거합니다.
2단계: 덤프 로그 및 직렬 콘솔 사용
Important
이 절, 방법 또는 작업에는 레지스트리를 수정하는 방법에 대한 단계가 포함되어 있습니다. 그러나 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 따라서 다음 단계를 신중하게 수행해야 합니다. 보호하기 위해 레지스트리를 수정하기 전에 백업하여 문제가 발생할 경우 레지스트리를 복원할 수 있도록 합니다. 레지스트리를 백업하고 복원하는 방법에 대한 자세한 내용은 Windows에서 레지스트리를 백업 및 복원하는 방법을 참조하십시오.
덤프 로그 및 직렬 콘솔을 사용하도록 설정하려면 다음 단계를 수행합니다.
관리자 권한으로 관리자 권한 명령 프롬프트 세션을 엽니다.
/ems 및 /emssettings 옵션을 사용하여 다음 BCDEdit 명령을 실행합니다.
직렬 콘솔을 사용하도록 설정합니다.
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
OS 디스크의 여유 공간이 VM의 RAM(메모리 크기)보다 큰지 확인합니다.
OS 디스크에 공간이 부족한 경우 메모리 덤프 파일이 만들어지는 위치를 변경하고 사용 가능한 공간이 충분한 VM에 연결된 모든 데이터 디스크를 참조합니다. 위치를 변경하려면 다음 명령에서 데이터 디스크의 드라이브 문자(예: )로
F:
바%SystemRoot%
꿉니다.OS 덤프 파일을 사용하도록 설정하려면 다음 로드, 추가 및 언로드 명령을 실행하여 reg 도구를 사용하여 제안된 구성을 구현합니다.
끊어진 OS 디스크에서 레지스트리 하이브를 로드합니다.
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
ControlSet001에서 사용하도록 설정합니다.
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
ControlSet002에서 사용하도록 설정합니다.
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
끊어진 OS 디스크를 언로드합니다.
reg unload HKLM\<broken-system>
디스크에 RAM만큼의 메모리를 할당할 수 있는 충분한 공간이 있는지 확인합니다. 이 VM에 대해 선택하는 크기에 따라 달라집니다. 공간이 부족하거나 크기가 큰 VM(G, GS 또는 E 시리즈)인 경우 이 파일을 만드는 위치를 변경하고 VM에 연결된 다른 데이터 디스크를 참조할 수 있습니다. 이렇게 하려면 다음 코드와 같이 레지스트리 키를 수정해야 합니다.
reg load HKLM\BROKENSYSTEM F:\windows\system32\config\SYSTEM
REG ADD "HKLM\BROKENSYSTEM\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "<DRIVE LETTER OF YOUR DATA DISK>:\MEMORY.DMP" /f
REG ADD "HKLM\BROKENSYSTEM\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "<DRIVE LETTER OF YOUR DATA DISK>:\MEMORY.DMP" /f
reg unload HKLM\BROKENSYSTEM
3단계: 메모리 덤프 프로세스 트리거
OS 디스크를 분리한 다음 영향을 받는 VM에 OS 디스크를 다시 연결합니다.
VM을 시작하고 직렬 콘솔에 액세스합니다.
NMI(마스크할 수 없는 인터럽트) 보내기를 선택하여 메모리 덤프를 트리거합니다.
1단계의 지침에 따라 덤프 파일을 다시 수집합니다.
도움을 요청하십시오.
질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.