SLA 사용 엔터티로 구성된 관리형 솔루션을 삭제할 수 없습니다.
이 문서에서는 Dynamics 365 Customer Service에서 SLA(서비스 수준 계약) 사용 엔터티로 구성된 관리되는 솔루션을 삭제할 수 없는 문제에 대한 해결을 제공합니다.
증상
SLA를 사용하도록 설정된 엔터티를 포함하는 관리형 솔루션은 삭제할 수 없습니다. 이 엔터티는 이전에 가져온 솔루션의 일부로 만들어졌습니다.
원인
엔터티에서 사용하도록 설정하면 SLA를 사용하지 않도록 설정할 수 없습니다.
이 예제를 사용하여 문제를 이해합니다.
- Org1에서 새 솔루션을 만들고 필드 솔루션으로 이름을 지정합니다.
- 필드 솔루션에서 새 엔터티를 만들고 필드 작업으로 이름을 지정합니다.
- 필드 솔루션을 관리형 솔루션으로 내보냅니다.
- 필드 솔루션을 Org2라는 새 조직으로 가져옵니다.
다음:
- Org1에서 다른 솔루션을 만들고 델타 필드 솔루션으로 이름을 지정합니다.
- 엔터티 필드 작업을 델타 필드 솔루션과 연결합니다. 엔터티에서 SLA를 사용하도록 설정합니다.
- 델타 필드 솔루션을 관리형 솔루션으로 내보냅니다.
- 델타 필드 솔루션을 Org2로 가져옵니다.
이제 Org2에서 Delta Field 솔루션을 삭제하려고 하면 SLA를 사용하도록 설정된 필드 작업 엔터티가 연결되어 있으므로 삭제할 수 없습니다.
해결
SLA 사용 엔터티를 사용하여 관리형 솔루션을 삭제하려면 먼저 엔터티 항목을 만든 이전에 가져온 관리형 솔루션을 삭제해야 합니다. 이 작업을 수행하면 엔터티 항목이 삭제됩니다. 그런 다음 엔터티를 다시 만들거나 관리형 솔루션을 가져올 수 있습니다.
Org2에서 델타 필드 솔루션을 삭제하려면 먼저 필드 솔루션을 삭제합니다.
필드 솔루션과 연결된 엔터티(필드 작업)가 SLA를 사용하도록 설정되지 않았으므로 필드 솔루션을 삭제할 수 있습니다. 필드 솔루션을 삭제하면 SLA 구성과 엔터티가 모두 삭제됩니다.
참고 항목
기본 엔터티 또는 기본 제공 엔터티가 연결된 관리형 솔루션을 삭제할 수 없으므로 이 해결 방법은 기본 제공 엔터티에서 작동하지 않습니다.