Corrigir incompatibilidade de ID de usuário do site no SharePoint ou OneDrive
Sintomas
Quando os usuários em sua organização tentam acessar um site do OneDrive ou do SharePoint usando uma nova conta que compartilha um nome de usuário com uma conta anterior, os usuários enfrentam um ou mais dos seguintes problemas:
- Uma mensagem de erro "Acesso negado"
- Uma experiência de usuário inconsistente
- Um novo site do OneDrive que tem um sufixo acrescentado à URL esperada, como
https://contoso-my.sharepoint.com/personal/UserA_Contoso_com1
(o sufixo pode ser um número ou um GUID)
Motivo
Esses problemas geralmente ocorrem se uma conta de usuário for excluída do Centro de administração do Microsoft 365 e, em seguida, uma nova conta for criada usando o nome UPN (nome UPN) usado pela conta excluída. A nova conta recebe um novo valor de ID, embora o UPN seja o mesmo. No entanto, a lista UserInfo para os sites do SharePoint e do OneDrive associados à conta tem apenas a ID antiga. Quando os usuários tentam acessar um site do SharePoint ou do OneDrive usando sua nova conta, sua nova ID não corresponde à ID que está na lista UserInfo. Portanto, eles têm acesso negado ao site.
Esses problemas também podem ocorrer durante a sincronização de diretório entre uma unidade organizacional (UO) do Active Directory e o SharePoint. Se os usuários já tiverem feito logon no SharePoint e forem movidos posteriormente para uma UO diferente, eles poderão enfrentar esses problemas quando a UO for sincronizada com o SharePoint.
Resolução
Para corrigir esses problemas, execute o diagnóstico de incompatibilidade de usuário do site usando uma conta de administrador do SharePoint.
Observação
- Esse diagnóstico não está disponível para os ambientes GCC High ou DoD ou para o Microsoft 365 operado pela 21Vianet.
- Antes que os administradores executem o diagnóstico para corrigir os problemas dos sites do OneDrive, eles devem verificar se o nome de usuário da nova conta de usuário corresponde à conta antiga. Os administradores estão proibidos de conectar sites do OneDrive que possam pertencer anteriormente a outra conta de usuário.
- Se o diagnóstico tiver resolvido com êxito um problema relacionado a um site do OneDrive, as alterações poderão levar aproximadamente 24 horas para ocorrer. Esse período inclui a atualização do bloco do OneDrive para apontar para o site correto e a reciclagem de todos os sites adicionais do OneDrive.
Selecione o botão Executar Testes a seguir para preencher o diagnóstico no Centro de administração do Microsoft 365. O diagnóstico executa uma grande variedade de validações para usuários internos e convidados que tentam acessar sites do SharePoint e do OneDrive.
Quando solicitado, forneça as seguintes informações:
- A conta de usuário afetada, como UserA@contoso.com
- O URL original do site, como
https://contoso-my.sharepoint.com/personal/UserA_Contoso_com
Para obter a URL original do site do OneDrive, siga estas etapas:
- Entre no site do OneDrive usando uma conta de administrador.
- Selecione o ícone Configurações (engrenagem) no canto superior direito.
- Selecione Configurações do OneDrive e, em seguida, selecione Mais Configurações.
- Na seção Informações de Diagnóstico, copie a URL da Web do OneDrive.
Para recuperar várias URLs do OneDrive, use um dos métodos em Exibir URLs do OneDrive para usuários em sua organização.
Cenários comuns
O diagnóstico de incompatibilidade do usuário do site pode corrigir os seguintes problemas comuns que podem ocorrer quando uma nova conta é criada usando o UPN usado por uma conta excluída.
Um usuário é direcionado para um novo site do OneDrive que tem um sufixo acrescentado à URL esperada
Quando uma nova conta de usuário é criada, um novo site do OneDrive é atribuído a ela. Quando uma conta de usuário é excluída, o site do OneDrive atribuído à conta não é excluído imediatamente. Portanto, se uma nova conta de usuário for criada usando o UPN de uma conta excluída, o novo site do OneDrive atribuído à nova conta terá a mesma URL que o site antigo do OneDrive, juntamente com um sufixo adicionado. Esse sufixo é um número ou um GUID.
Se você quiser que a nova conta de usuário use o mesmo site do OneDrive que foi atribuído à conta antiga, o diagnóstico verificará se o usuário pode receber a propriedade do site original. Depois de verificar com êxito as permissões do usuário, o diagnóstico oferecerá a reconexão do usuário ao site original e a reciclagem do novo site ativo que possui o sufixo .https://contoso-my.sharepoint.com/personal/UserA_Contoso_com1
Se você precisar acessar o conteúdo no novo site do OneDrive posteriormente, poderá restaurar o OneDrive excluído.
Acesso negado a um site do OneDrive
Se um usuário tiver acesso negado ao site antigo do OneDrive depois que uma nova conta for criada para ele, o diagnóstico reconfigurará o perfil do usuário. Em seguida, ele reconectará o usuário ao site antigo do OneDrive para corrigir o problema de acesso.
Observação
Os administradores não podem corrigir esse problema atualizando manualmente os proprietários do site do OneDrive ou editando as propriedades de perfil de usuário associadas ao site do OneDrive. O diagnóstico é a única solução recomendada para corrigir esse problema.
Incompatibilidade de ID de usuário em sites do SharePoint ou sites do OneDrive que não pertencem ao usuário
Quando o diagnóstico detecta uma incompatibilidade de ID de usuário na lista UserInfo, ele se oferece para remover a ID antiga. Depois de aceitar a oferta e a ID antiga ser removida, atribua à nova conta de usuário as permissões apropriadas ao site do SharePoint.
Observação: Se você quiser corrigir esse problema manualmente, deverá remover a conta de usuário antiga da lista UserInfo e conceder permissões à nova conta de usuário.
Mais informações
Para obter mais informações sobre problemas de acesso no SharePoint e no OneDrive, consulte Erros de "Acesso negado" ou "Você precisa de permissão" no SharePoint Online e no OneDrive.