Compartilhar via


Falha de backup do Estado do Sistema do Agente do Microsoft Azure Recovery Services (ID de erro 8007007B)

Este artigo descreve os sintomas e a resolução de um erro que ocorre quando você faz backup do Estado do Sistema usando o Agente MARS (Microsoft Azure Recovery Services).

Versão original do produto: Backup do Azure
Número de KB original: 4053355

Sintomas

Uma das mensagens de erro a seguir aparece na guia Erros da caixa de diálogo Detalhes do Trabalho que corresponde a um trabalho de backup do Estado do Sistema com falha no console do Microsoft Azure Recovery Services Agent.

Não foi possível executar a operação, pois o trabalho de Backup do Windows Server falhou com a mensagem de erro: nenhum dos itens incluídos no backup foi feito com backup. Erro detalhado: o nome do arquivo, o nome do diretório ou a sintaxe do rótulo de volume estão incorretos HResult: 80780049 DetailedHResult: 8007007B Goto https://go.microsoft.com/fwlink/?linkid=847810 para corrigir isso. (0x1873D)

O Windows Server não conseguiu fazer backup de estado do sistema porque um gravador de sistema relatou um caminho inválido. Mensagem de erro de backup do Windows Server: a sintaxe de nome do arquivo, nome do diretório ou rótulo de volume está incorreta HResult: 80780049 DetailedHResult: 8007007B Goto https://go.microsoft.com/fwlink/?linkid=859092 para corrigir isso. (0x18770)

Captura de tela do erro de falha do trabalho para backup do Estado do Sistema.

Quando você clica em Logs de Falha do WSB, um arquivo é aberto que contém uma mensagem de erro que se assemelha ao seguinte:

Erro no backup de Systemroot_pathduring enumerar: Erro [0x8007007b] O nome do arquivo, o nome do diretório ou a sintaxe do rótulo de volume estão incorretos.

Motivo

Esse erro ocorre quando a especificação de arquivo necessária para enumerar arquivos que devem ser backup como parte do Estado do Sistema do Windows Server é atualizada incorretamente.

Solução

Aviso

Poderão ocorrer sérios problemas se você modificar o Registro incorretamente com o Editor do Registro ou outro método. Talvez seja necessária a reinstalação do sistema operacional. A Microsoft não pode garantir que esses problemas possam ser resolvidos. Modifique o Registro a seu próprio risco.

Para garantir que a especificação do arquivo seja atualizada, siga estas etapas:

  1. No arquivo aberto quando você clicar em Logs de Falha do WSB, verifique se o Systemroot_path está correto. Por exemplo, Systemroot_path na seguinte mensagem de erro deve se assemelhar a C:\Windows\\systemroot\:

    Erro no backup de c:\windows\systemroot\ durante a enumeração: Erro [0x8007007b] O nome do arquivo, o nome do diretório ou a sintaxe do rótulo de volume estão incorretos.

  2. Execute o seguinte comando em um prompt de comando elevado:

    diskshadow /l Output_File_Path
    

    Observação

    O espaço reservado Output_File_Path deve se assemelhar C:\outputfilepath.txta .

  3. Digite os seguintes comandos em um prompt DISKSHADOW e pressione Enter após cada comando:

    list writers detailed
    
    exit  
    
  4. Abra o arquivo de saída especificado na etapa 2.

  5. Localize a linha que contém Systemroot_path (C:\Windows\\systemroot\ em nosso exemplo acima). Por exemplo, a linha deve se assemelhar à seguinte: Lista de Arquivos: Caminho = Systemroot_path\system32\drivers, Filespec = File_Spec_Path

    Por exemplo:

    Lista de Arquivos: Caminho = C:\windows\\systemroot\system32\drivers, Filespec = winmad.sys

  6. Inicie o Editor do Registro. Para fazer isso, clique com o botão direito do mouse em Iniciar, clique em Executar, digite regedit na caixa Abrir e clique em OK.

  7. Localize a seguinte subchave: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

  8. Clique com o botão direito do mouse em Serviços e clique em Localizar.

    Captura de tela da opção localizar em serviços no Editor do Registro.

  9. Na caixa Localizar qual , digite o caminho File_Spec_Path que você encontrou na etapa 5 e clique em Localizar Próximo.

    Captura de tela do caminho File_Spec_Path em localizar qual caixa.

    Exemplo:

    Captura de tela do exemplo em localizar qual caixa.

    Os resultados da pesquisa contarão com uma chave de registro chamada ImagePath. Se seu valor tiver um backslash principal '', clique duas vezes nesse valor e remova-o. Se o valor não começar com um backslash, envie uma solicitação de suporte do portal do Azure.

    Antes da alteração Após a alteração
    Captura de tela dos resultados da pesquisa para o imagepath antes da alteração.
    Captura de tela dos resultados da pesquisa para o imagepath após a alteração.
  10. Voltar ao console do MARS Agent e inicie um Backup de Estado do Sistema clicando em Fazer Backup Agora.

Entre em contato conosco para obter ajuda

Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.