Compartilhar via


O Windows mostra a “verificação do sistema de arquivos” ao inicializar uma VM do Azure

Aplica-se a: ✔️ VMs do Windows

Este artigo descreve o erro "Verificando o sistema de arquivos" que você pode encontrar ao inicializar uma VM (Máquina Virtual) do Windows no Microsoft Azure.

Sintoma

Uma VM do Windows não inicia. Ao verificar as capturas de tela de inicialização em Diagnóstico de inicialização, você verá que o processo Verificar disco (chkdsk.exe) está sendo executado com uma das seguintes mensagens:

  • Digitalizando e reparando a unidade (C:)
  • Verificando o sistema de arquivos em C:

Motivo

Se um erro NTFS for encontrado no sistema de arquivos, o Windows verificará e reparará a consistência do disco na próxima reinicialização. Normalmente, isso acontece se a VM teve uma reinicialização inesperada ou se o processo de desligamento da VM foi interrompido abruptamente.

Solução

Dica

Se você tiver um backup recente da VM, tente restaurar a VM do backup para corrigir o problema de inicialização.

O Windows inicializará normalmente após a conclusão do processo de verificação do disco. Se a VM estiver travada no processo Check Disk, tente executar o Check Disk na VM offline:

  1. Faça um instantâneo do disco do sistema operacional da VM afetada como um backup. Para saber mais, consulte Instantâneo de um disco.

  2. Anexe o disco do sistema operacional a uma VM de reparo.

  3. Na VM de reparo, execute Verificar Disco no disco do sistema operacional anexado. No exemplo a seguir, a letra do driver do disco do sistema operacional anexado é E:

    chkdsk E: /f
    
  4. Após a conclusão da verificação do disco, desanexe o disco da VM de reparo e anexe novamente o disco à VM afetada como um disco do sistema operacional. Para obter mais informações, consulte Solucionar problemas de uma VM do Windows anexando o disco do sistema operacional a uma VM de reparo por meio do portal do Azure.

Entre em contato conosco para obter ajuda

Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.