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O Windows mostra um erro de tela azul durante a inicialização de uma VM do Azure

Aplica-se a: ✔️ Windows VMs

Este artigo descreve os erros de tela azul que você pode encontrar ao inicializar uma VM (Máquina Virtual) do Windows no Microsoft Azure. Ele fornece as etapas para ajudar você a coletar dados para um tíquete de suporte.

Sintomas

Uma VM do Windows não inicia. Ao verificar as capturas de tela de inicialização no Diagnóstico de inicialização, você verá uma das seguintes mensagens de erro em uma tela azul:

Seu PC teve um problema e precisa ser reiniciado. Estamos apenas coletando algumas informações sobre o erro e, em seguida, você pode reiniciá-lo.

Seu PC teve um problema e precisa ser reiniciado.

Causa

Pode haver muitos motivos pelos quais você experimenta um erro de parada. As causas mais comuns são os seguintes problemas:

  • Problema em um driver
  • Memória ou arquivo do sistema corrompido
  • Um aplicativo acessando um setor proibido da memória

Solução

Dica

Se você tiver um backup recente da VM, tente restaurar a VM do backup para corrigir o problema de inicialização.

Para resolver esse problema, primeiro você precisa coletar um arquivo de despejo para a falha antes de entrar em contato com o suporte. Para coletar o arquivo de despejo, siga estas etapas:

Etapa 1: Localize o arquivo de despejo e envie um tíquete de suporte

Parte 1: Anexar o disco do sistema operacional a uma VM de recuperação
  1. Faça um instantâneo do disco do sistema operacional da VM afetada para criar um backup. Para obter mais informações, consulte Criar um instantâneo de um disco rígido virtual.

  2. Anexe o disco do SO a uma VM de recuperação.

  3. Use o protocolo RDP (Remote Desktop Protocol) para se conectar remotamente à VM de recuperação.

  4. Se o disco do sistema operacional da VM afetada estiver criptografado, desative a criptografia antes de ir para a próxima etapa. Para obter mais informações, consulte Descriptografar o disco criptografado do sistema operacional.

Parte 2: Localize o arquivo de despejo e envie um tíquete de suporte
  1. Na VM de recuperação, vá para a pasta Windows no disco do sistema operacional anexado. Por exemplo, se a letra da unidade atribuída ao disco do sistema operacional anexado for F, vá para F:\Windows.

  2. Localize o arquivo Memory.dmp e, em seguida , envie um tíquete de suporte e anexe o arquivo de despejo.

Se você não conseguir encontrar o arquivo de despejo, vá para as próximas etapas para habilitar o log de despejo e o console serial e reproduza o problema.

Etapa 2: Habilitar o log de despejo e o console serial

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, certifique-se de seguir essas etapas com atenção. Para maior proteção, faça backup do Registro antes de modificar, para poder restaurar se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o Registro, consulte Como fazer backup e restaurar o Registro no Windows.

Para habilitar o log de despejo e o console serial, siga estas etapas:

  1. Abra uma sessão de prompt de comando com privilégios elevados como administrador.

  2. Execute os seguintes comandos BCDEdit usando as opções /ems e /emssettings :

    Habilite o console serial:

    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON
    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
    
  3. Verifique se o espaço livre no disco do sistema operacional é maior ao tamanho da memória (RAM) na VM.

    Se não houver espaço suficiente no disco do sistema operacional, altere o local em que o arquivo de despejo de memória é criado e encaminhe esse local para qualquer disco de dados anexado à VM que tenha espaço livre suficiente. Para alterar o local, substitua %SystemRoot% pela letra da unidade do disco de dados, como F:, nos comandos a seguir.

    Para habilitar o arquivo de despejo do sistema operacional, execute os seguintes comandos load, add e unload para implementar a configuração sugerida usando a ferramenta reg :

    Carregue o hive do registro do disco do sistema operacional quebrado:

    reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
    

    Habilitar em ControlSet001:

    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Habilitar em ControlSet002:

    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Descarregue o disco do sistema operacional quebrado:

    reg unload HKLM\<broken-system>
    

Etapa 3: reproduzir o problema

  1. Desanexe o disco do sistema operacional e reconecte o disco do sistema operacional à VM afetada.

  2. Inicie a VM para reproduzir o problema para que um arquivo de despejo seja gerado.

  3. Repita as instruções na seção Etapa 1: Localize o arquivo de despejo e envie um tíquete de suporte.

Entre em contato conosco para obter ajuda

Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.