Os clientes do Configuration Manager são reinstalados a cada cinco horas e podem causar uma atualização inadvertida do cliente
Este artigo discute um problema no cliente do System Center 2012 Configuration Manager e no cliente do System Center 2012 R2 Configuration Manager que pode causar uma atualização inadvertida do cliente em um ambiente de branch atual ou LTSB (branch de manutenção de longo prazo) do Configuration Manager.
Versão original do produto: Microsoft System Center 2012 Configuration Manager, Microsoft System Center 2012 R2 Configuration Manager
Número original do KB: 4018655
Resumo
A instalação do cliente do Configuration Manager (CCMSetup) falha inicialmente e faz com que uma tarefa de repetição do cliente seja registrada no Agendador de Tarefas do Windows. Depois que a instalação do cliente for bem-sucedida, a tarefa de repetição não será excluída conforme o esperado. Portanto, os clientes continuam a reinstalar a cada cinco horas.
Nessa situação, se você atualizar a infraestrutura do Configuration Manager para o branch atual do Configuration Manager ou LTSB e se não atualizar os clientes do Configuration Manager, a tarefa de repetição agendada continuará a forçar uma reinstalação do cliente a cada cinco horas.
Na próxima vez que o CCMSetup for executado, os clientes encontrarão um ponto de gerenciamento ou ponto de distribuição atualizado e reinstalarão o software cliente. Isso atualiza os clientes para o Configuration Manager.
Essas atualizações contínuas ocorrem fora do processo normal de atualização configurado pelo administrador. Isso inclui o recurso de pilotagem do cliente.
Sintomas
Em um ambiente do Microsoft System Center 2012 ou System Center 2012 R2, você observa os seguintes sintomas:
- Os clientes se reinstalam com sucesso a cada cinco horas. Essa atividade é registrada nos logs de eventos do ccmsetup.log e do Windows.
- Ao exibir a pasta \Microsoft\Microsoft\ConfigurationManager no Agendador de Tarefas, você encontra uma tarefa chamada Tarefa de Repetição do Cliente do Configuration Manager.
Causa
Esse problema ocorre porque o CCMSetup cria a tarefa de repetição do cliente na pasta errada no cliente. Isso impede que o CCMSetup localize e remova a tarefa.
A tarefa agendada é criada na pasta \Microsoft\Microsoft\Configuration Manager em vez da pasta \Microsoft\Configuration Manager.
Solução alternativa 1
Remova manualmente a Tarefa de Repetição do Cliente do Configuration Manager da pasta \Microsoft\Microsoft\Configuration Manager usando o Agendador de Tarefas.
Solução alternativa 2
Implante um script para remover a Tarefa de Repetição do Cliente do Configuration Manager da pasta \Microsoft\Microsoft\Configuration Manager.
Exemplo de comandos do Windows PowerShell para adicionar ao seu script:
get-scheduledtask -taskname "Configuration Manager Client Retry Task"
unregister-scheduledtask -taskname "Configuration Manager Client Retry Task" -confirm:$false
Mais informações
No Configuration Manager branch atual versão 1602 e versões posteriores e no LTSB versão 1606, o Ccmsetup remove corretamente a tarefa agendada depois que os clientes são atualizados.