A configuração de email de proteção de redefinição de fábrica não é imposta depois que você redefinir um dispositivo Android Enterprise
Este artigo fornece uma solução para o problema de que a configuração de emails de proteção de redefinição do Factory não funciona conforme o esperado para um dispositivo Android Enterprise Device Owner registrado.
Sintomas
Considere o seguinte cenário:
Você tem um dispositivo Android Enterprise registrado no Microsoft Intune.
A configuração de emails de proteção de redefinição de fábrica está habilitada e um endereço de email é fornecido, conforme mostrado na seguinte captura de tela:
Você faz uma redefinição de fábrica no dispositivo por meio do menu Configurações (por exemplo, toque em Configurações>Gerenciamento> geralRedefinir redefinição> dedados do Factory) ou limpe o dispositivo de Intune no centro de administração Microsoft Intune.
Nesse cenário, você pode ativar o dispositivo usando uma conta do Google que não está incluída na configuração de email de proteção de redefinição do Factory .
Motivo
Esse comportamento é esperado. Quando você faz uma redefinição de fábrica no dispositivo por meio do menu Configurações ou apaga o dispositivo de Intune no centro de administração Microsoft Intune, todos os seus dados são removidos. Isso inclui os dados FRP (Factory Reset Protection).
Solução
A única maneira de fazer uma redefinição de fábrica no dispositivo sem perder os dados FRP é por meio do Modo de Recuperação.
Recomendamos que você defina o valor de redefinição de fábrica como Bloquear para impedir que os usuários usem a opção de redefinição de fábrica nas configurações do dispositivo.
Em seguida, use um dos seguintes métodos ao redefinir o dispositivo para as configurações de fábrica:
- Redefinir o dispositivo por meio do modo Recovery.
- Limpe o dispositivo de Intune quando o dispositivo estiver em sua posse e espera-se que seja redefinido para uso adicional.