"Atualizar tudo" não funciona depois de exportar dados do aplicativo para uma planilha dinâmica
Sintomas
Use o comando Exportar para Excel para exportar dados do aplicativo para uma planilha dinâmica. Em seguida, abra o arquivo baixado e atualize os dados selecionando Data>Refresh All. Nessa situação, você descobre que os dados desaparecem e a pasta de trabalho aparece em branco. Você deve ver a seguinte mensagem de erro:
Essa consulta da Web não retornou dados. Para alterar a consulta, clique em OK, clique na seta na caixa de nome na barra de fórmulas, clique no nome do intervalo de dados externos da consulta na Web, clique com o botão direito do mouse na seleção e clique em Editar Consulta.
Causa
Esse problema ocorre quando os dados que você acessa são protegidos por senha e o arquivo do Excel não pode enviar senhas para fontes de dados externas.
Solução
Para resolver esse problema, você deve editar e salvar a consulta da Web.
No arquivo do Excel, selecione Consultas e conexões de dados>.
O painel Consultas e conexões é aberto à direita da janela. Na guia Conexões , clique com o botão direito do mouse na consulta e selecione Propriedades.
A janela Propriedades de Conexão é aberta. Na guia Definição , selecione Editar Consulta.
Se solicitado, digite o nome de usuário e a senha. Insira as mesmas informações de usuário e senha que você usa para fazer login no aplicativo.
Na janela Editar Consulta da Web, selecione Ir. Ocorre uma mensagem de erro:
Não é possível concluir esta ação
Feche a janela Editar Consulta da Web.
Isso deve resolver o problema. Atualize os dados na planilha novamente selecionando Atualizar tudo de dados>.
Se as etapas acima não resolverem o problema, siga estas etapas adicionais:
Insira o link a seguir na barra de endereços da janela Editar Consulta na Web para acessar a página Configurações Avançadas no Microsoft Dynamics 365 Customer Engagement. Lembre-se de substituir
OrgURL
pelo URL da sua organização.https://OrgURL/main.aspx?settingsonly=true
Saia usando o link de opção de perfil no canto superior direito e entre novamente usando a identidade correta.
Depois de entrar, feche a janela Editar Consulta da Web e, no arquivo do Excel, selecione Atualizar Tudo de Dados>. Os dados serão atualizados conforme o esperado.