Compartilhar via


"Atualizar tudo" não funciona depois de exportar dados do aplicativo para uma planilha dinâmica

Sintomas

Use o comando Exportar para Excel para exportar dados do aplicativo para uma planilha dinâmica. Em seguida, abra o arquivo baixado e atualize os dados selecionando Data>Refresh All. Nessa situação, você descobre que os dados desaparecem e a pasta de trabalho aparece em branco. Você deve ver a seguinte mensagem de erro:

Essa consulta da Web não retornou dados. Para alterar a consulta, clique em OK, clique na seta na caixa de nome na barra de fórmulas, clique no nome do intervalo de dados externos da consulta na Web, clique com o botão direito do mouse na seleção e clique em Editar Consulta.

A captura de tela que mostra que a consulta da Web não retornou nenhum erro de dados que ocorre depois que você atualiza os dados do aplicativo exportados.

Causa

Esse problema ocorre quando os dados que você acessa são protegidos por senha e o arquivo do Excel não pode enviar senhas para fontes de dados externas.

Solução

Para resolver esse problema, você deve editar e salvar a consulta da Web.

  1. No arquivo do Excel, selecione Consultas e conexões de dados>.

    Captura de tela que mostra a opção Consultas e Conexões na guia Dados.

  2. O painel Consultas e conexões é aberto à direita da janela. Na guia Conexões , clique com o botão direito do mouse na consulta e selecione Propriedades.

    Captura de tela que mostra as configurações de Propriedades de uma consulta no painel Consultas e Conexões.

  3. A janela Propriedades de Conexão é aberta. Na guia Definição , selecione Editar Consulta.

    Captura de tela que mostra o botão Editar Consulta na janela Propriedades da Conexão.

  4. Se solicitado, digite o nome de usuário e a senha. Insira as mesmas informações de usuário e senha que você usa para fazer login no aplicativo.

  5. Na janela Editar Consulta da Web, selecione Ir. Ocorre uma mensagem de erro:

    Não é possível concluir esta ação

    Captura de tela que mostra o botão Ir na janela Editar Consulta da Web.

  6. Feche a janela Editar Consulta da Web.

  7. Isso deve resolver o problema. Atualize os dados na planilha novamente selecionando Atualizar tudo de dados>.

    Captura de tela que mostra como atualizar os dados do seu aplicativo no Excel.

Se as etapas acima não resolverem o problema, siga estas etapas adicionais:

  1. Insira o link a seguir na barra de endereços da janela Editar Consulta na Web para acessar a página Configurações Avançadas no Microsoft Dynamics 365 Customer Engagement. Lembre-se de substituir OrgURL pelo URL da sua organização.

    https://OrgURL/main.aspx?settingsonly=true

  2. Saia usando o link de opção de perfil no canto superior direito e entre novamente usando a identidade correta.

  3. Depois de entrar, feche a janela Editar Consulta da Web e, no arquivo do Excel, selecione Atualizar Tudo de Dados>. Os dados serão atualizados conforme o esperado.

Confira também

Exportar dados para uma planilha dinâmica do Excel