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Erros de conexão intermitentes ocorrem ao adicionar um nó ao ambiente Always On no SQL Server

Você experimenta erros de conexão intermitentes ao adicionar um novo nó ao ambiente Always On existente.

Sintomas

Quando você tenta se conectar a um servidor que está executando o Microsoft SQL Server, a seguinte mensagem de erro é exibida intermitentemente:

A conexão foi estabelecida com êxito com o servidor, mas ocorreu um erro durante o processo de login. (provedor: Provedor SSL, erro: 0 - Uma conexão existente foi fechada à força pelo host remoto.)

Motivo

Esse erro pode ocorrer se houver uma incompatibilidade nos protocolos de segurança entre o banco de dados e os servidores de aplicativos.

Resolução

Para corrigir esse erro, resolva a incompatibilidade entre os protocolos de segurança. O Node1 criptografa informações usando AES128/256. O Node2 criptografa informações usando RC4. Para solucionar esse erro, siga estas etapas:

  1. Baixe o IIS Crypto.

  2. Instale a versão GUI da ferramenta IIS Crypto no servidor.

  3. Configurar os Conjuntos de Criptografia.

  4. Abra a ferramenta Criptografia do IIS no servidor.

  5. Na interface de criptografia do IIS, selecione Cipher Suites no painel esquerdo.

  6. Na lista, desmarque todas as caixas de seleção para cifras que começam com "TLS_DHE*".

    Observação

    A lista pode não estar em nenhuma ordem específica.

  7. Depois de limpar as seleções de criptografia relevantes, selecione Aplicar para salvar as alterações.

    Captura de tela que mostra a limpeza de todas as cifras que não são necessárias.

  8. Reinicie o servidor.

    Depois que as alterações forem aplicadas, reinicie o servidor para garantir que a nova configuração do conjunto de criptografia entre em vigor.

Observação

Esse processo de solução de problemas força o cliente a se comunicar usando um conjunto de criptografia diferente que tem uma implementação de segurança aprimorada.

Certifique-se sempre de ter os backups apropriados disponíveis. Além disso, considere testar quaisquer alterações em um ambiente controlado, preparado ou de teste antes de aplicá-las aos computadores de produção. Se o problema persistir ou se você tiver outras preocupações, entre em contato com sua equipe de rede.

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