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403: Erro proibido ao tentar ver informações de livre/ocupado em toda a organização no Exchange

Número original da BDC: 3082946

Resumo

Quando tenta ver informações de disponibilidade em toda a organização, a tentativa falha e gera um erro 403: Proibido .

Por exemplo, tem a Floresta A num servidor com o Microsoft Exchange 2007 e a Floresta B num servidor com Exchange Server 2013 ou Exchange Server 2010. Nesta situação, um utilizador na Floresta A não consegue ver as informações de disponibilidade de um utilizador na Floresta B. Além disso, o seguinte evento é registado no registo de eventos no servidor de origem:

Log Name:      Application

Source:        MSExchange Availability

Date:          Date

Event ID:      4002

Task Category: Availability Service

Level:         Error

Keywords:      Classic

User:          N/A

Computer:      <Computer Name>

Description:

Process <Process ID>[w3wp.exe:/LM/W3SVC/1/ROOT/EWS-1-130778800910201315]: Proxy request CrossForest from
Requester:S-1-5-21-1016748826-3068013645-1401187561-1105 to https://<ONLINE_URL>/EWS/Exchange.asmx failed.
Caller SIDs: . The exception returned is Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequestProcessingException:
System.Net.WebException: The request failed with HTTP status 403: Forbidden.

No servidor de destino, é registada a seguinte entrada no registo do Serviço de Informação Internet (IIS), no diretório W3SVC1:

IIS Logs:  2015-06-08 04:19:25 <IP Address> POST /EWS/Exchange.asmx &CorrelationID=<empty>;&ClientId=JQJLGECZ0MGEHVVWEBZG&cafeReqId=9f422915-0721-48ce-b2c6-4406d2c1b49d; 443 domain\serviceaccount <IP Address> ASProxy/CrossForest/EmailDomain/EXCH/08.03.0083.000 - 403 0 0 718

No servidor que está a ser executado Exchange Server 2013, é registada a seguinte entrada no registo HTTPProxy:

WebExceptionStatus=ProtocolError;ResponseStatusCode=403;WebException=System.Net.WebException: The remote server returned an error: (403) Forbidden.    at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)    at Microsoft.Exchange.HttpProxy.ProxyRequestHandler.<>c__DisplayClass2c.<OnResponseReady>b__2b();

No servidor da Caixa de Correio, é registada a seguinte entrada no registo do IIS, no diretório W3SVC2:

2015-06-08 04:16:29 <IP Address> POST /EWS/Exchange.asmx - 444 domain\serviceaccount 10.152.152.166 ASProxy/CrossForest/EmailDomain/EXCH/08.03.0083.000 403 0 0 233

No servidor da Caixa de Correio, é registada a seguinte entrada no registo EWS:

AuthError=User not allowed to access EWS;,FaultInnerException=Microsoft.Exchange.Services.Core.Types.ServiceAccessDeniedException: Access is denied. Check credentials and try again.;ExceptionHandlerBase_ProvideFault_FaultException=System.ServiceModel.FaultException: Access is denied. Check credentials and try again.    at Microsoft.Exchange.Services.Wcf.MessageInspectorManager.InternalAfterReceiveRequest(Message& request  IClientChann

Causa

Este problema ocorre porque o EWS está bloqueado na Floresta B ao nível da organização. A floresta B permite que apenas as aplicações selecionadas acedam ao EWS. O EWS não é permitido para pedidos de livre/ocupado entre florestas.

Para verificar a configuração da organização, execute o seguinte comando:

Get-Organizationconfig | fl *ews*

Resolução

Para ativar pedidos de livre/ocupado entre florestas ao nível da organização, tem de adicionar o Agente de utilizador à lista de Permissões do EWS. Por exemplo, na situação descrita na secção "Resumo", adicione o seguinte caminho do Agente de utilizador.

Nota

Estas informações são obtidas dos registos do IIS no servidor de destino.

ASProxy/CrossForest/EmailDomain/EXCH/08.03.0083.00

Em seguida, execute o seguinte comando:

Set-OrganizationConfig -EwsAllowList "ASProxy/CrossForest/EmailDomain/EXCH/08.03.0083.000","TestApp","app1"