Erro quando o Outlook para iOS ou Android se liga a Exchange Server: Ligação insegura ou Ligação segura indisponível
Número original da BDC: 4056392
Sintomas
Quando utiliza o Microsoft Outlook para iOS ou o Outlook para Android para iniciar sessão numa instância do Exchange Server que utiliza um certificado SSL para ligações seguras, recebe uma das seguintes mensagens de erro:
Ligação insegura. Quer iniciar sessão mesmo assim?
Ligação segura indisponível. Quer iniciar sessão mesmo assim?
Causa
Este problema ocorre porque o certificado SSL é considerado não suportado por um dos seguintes motivos:
- O certificado SSL é inválido ou expirou.
- O certificado SSL não é fidedigno.
Nota
O Outlook para iOS e o Outlook para Android utilizam as autoridades de certificação (ACs) fidedignas de Java padrão. Se o certificado da sua organização não for assinado por uma autoridade de certificação que faça parte das autoridades de certificação fidedignas de Java padrão, este erro ocorre.
Resolução
Pode ignorar esta mensagem de erro com segurança e iniciar sessão no Exchange Server. Esta mensagem de erro deve ser apresentada apenas uma vez.
Recomendamos que utilize um certificado SSL que seja oficialmente suportado pelo arquivo de certificados da AC Java.
Como verificar se um certificado é fidedigno pelas ACs Java
Obtenha a AC do certificado.
Transfira o Java SE Development Kit (JDK) mais recente. Este kit inclui as ACs fidedignas de Java.
Abra uma janela da Linha de Comandos num computador baseado no Windows ou abra uma janela do Terminal num computador baseado em macOS.
Utilize o utilitário keytool para listar as ACs fidedignas ao executar o seguinte comando:
keytool -keystore "<keystore location>" -storepass changeit -list -v
Nota
Num computador baseado em macOS, o parâmetro de localização> do <keystore pode ser "$JAVA_HOME/jre/lib/security/cacerts".
Verifique se a AC do certificado está na lista.
Para obter mais informações sobre o utilitário keytool, consulte os seguintes artigos: